Help with setting up postgresql module on metricbeat with elastic cloud


I did setup postgresql module using metricbeat on linux machine using following guide:

and command sudo metricbeat setup -e

everything works fine but I'm sending a huge amount of data to elastic cloud which is unmanageable, I tried to use some documents describing how to push my own fields and I done it leaving fields.yaml only with postgresql fields but it didn't help.

I stuck trying to setup metricbeat to only send postgresql related metrics every 10 seconds not all others including system, all I need is this one postgresql dashboard to have data.

Hi @idelix

Just To be be clear / precise

sudo metricbeat setup -e

Only sets up assets, dashboards, visualizations templates etc... into Kibana and Elasticsearch it does not actually ship the metrics that only happens when metricbeat is running.

The metricbeat system module is enabled by default. This module ships all the infrastructure metrics like RAM, CPU, Processes, I/O disk etc.

If you do not want that you should disable the system module.

sudo metricbeat modules disable system

you can run this command to see which modules are enabled.

sudo metricbeat modules list

Then restart metricbeat and it should only run the postgresql module.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.