High CPU on windows server 2012


(Wesley Creteur) #1

Hi everyone,

I'm using elasticsearch for my webshop products to have a fast
search/navigation and have approximate 5000 products (85000 documents
indexed). I'm using elasticsearch as service and it works fine, but it's
eating my CPU. I think my use of elasticsearch is very minimal and still my
CPU is hitting an avg of 97%. When i stop the service everything is going
back to normal, so i'm sure it's the elasticsearch (64-bits) service. Is
there anything i can do? I"m using windows server 2012, 4 CPU cores, 16 GB
RAM. I have (for now) 1 cluster with 1 node and 2 indexes of 5 shards. I'm
running elasticsearch on the same server of my website.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/00a510c2-c4f7-49d2-a4f6-93c84ead8ed8%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Wesley Creteur) #2

Would it help if i change my structure to 3 nodes, 1 shards and 2 replicas?

Op woensdag 12 februari 2014 09:07:53 UTC+1 schreef Wesley Creteur:

Hi everyone,

I'm using elasticsearch for my webshop products to have a fast
search/navigation and have approximate 5000 products (85000 documents
indexed). I'm using elasticsearch as service and it works fine, but it's
eating my CPU. I think my use of elasticsearch is very minimal and still my
CPU is hitting an avg of 97%. When i stop the service everything is going
back to normal, so i'm sure it's the elasticsearch (64-bits) service. Is
there anything i can do? I"m using windows server 2012, 4 CPU cores, 16 GB
RAM. I have (for now) 1 cluster with 1 node and 2 indexes of 5 shards. I'm
running elasticsearch on the same server of my website.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6394c55f-0b3b-4694-a411-e801d17cd408%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Binh Ly) #3

May I ask what is your ES_MAX_MEM setting? Is it possible that it is set
too low - like the default 1G?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6effe981-472b-4a0b-850d-addc00228c50%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Wesley Creteur) #4

I'm using 3Gb. Is that sufficient?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a8376d35-05fc-4efd-b388-10fc0b38c902%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Binh Ly) #5

I'd try to up it to 8GB, assuming of course you still have a lot (like
close to 8GB) free. If that still doesn't work, once you get to the high
CPU state, try to run this and it'll tell you what threads in ES is doing
what with the CPU:

curl "localhost:9200/_nodes/hot_threads?pretty"

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/630ca592-e078-41fe-b049-7a65a65c5b29%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6