High cpu usage after 0.9.13 to 1.0.3


(Maziyar Panahi) #1

Hi everyone,

Yesterday I change my source.list repository from 0.9 to 1.0 and upgrade my
ES to newer version and chose to not change the config file which it was
the default. Ever since I started ES the CPU usage is over the top.

I used to see high cpu usage in merging, my mongo-river, refreshing, and
Marvel exporting for a short period of time but this one always refers to
[management] which I don't know what is it.

Here the plugins I have: mapper-attachments, river-mongodb (these two are
updated to latest version and working fine with ES
1.0.3), paramedic, marvel, bigdesk, head.

What I really want to know is what that management refers to? Is it a
outdated plugin here that's not compatible and eating up the cpu or I
should have chosen new configuring file to overwrite my old one that
belonged to 0.9?

I also have Logstash 1.4 on the same machine with two nodes for two really
low traffic logs (maybe 60 docs top)

24.3% (121.5ms out of 500ms) cpu usage by thread 'elasticsearch[Master
node][management][T#1]'
10/10 snapshots sharing following 9 elements
sun.misc.Unsafe.park(Native Method)

java.util.concurrent.locks.LockSupport.parkNanos(LockSupport.java:226)

org.elasticsearch.common.util.concurrent.jsr166y.LinkedTransferQueue.awaitMatch(LinkedTransferQueue.java:702)

org.elasticsearch.common.util.concurrent.jsr166y.LinkedTransferQueue.xfer(LinkedTransferQueue.java:615)

org.elasticsearch.common.util.concurrent.jsr166y.LinkedTransferQueue.poll(LinkedTransferQueue.java:1117)

java.util.concurrent.ThreadPoolExecutor.getTask(ThreadPoolExecutor.java:1068)

java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130)

java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
java.lang.Thread.run(Thread.java:745)

24.0% (120.1ms out of 500ms) cpu usage by thread 'elasticsearch[Master
node][management][T#3]'
10/10 snapshots sharing following 9 elements
sun.misc.Unsafe.park(Native Method)

java.util.concurrent.locks.LockSupport.parkNanos(LockSupport.java:226)

org.elasticsearch.common.util.concurrent.jsr166y.LinkedTransferQueue.awaitMatch(LinkedTransferQueue.java:702)

org.elasticsearch.common.util.concurrent.jsr166y.LinkedTransferQueue.xfer(LinkedTransferQueue.java:615)

org.elasticsearch.common.util.concurrent.jsr166y.LinkedTransferQueue.poll(LinkedTransferQueue.java:1117)

java.util.concurrent.ThreadPoolExecutor.getTask(ThreadPoolExecutor.java:1068)

java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130)

java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
java.lang.Thread.run(Thread.java:745)

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/597af070-f968-46f6-b4da-9a7add37f9bf%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Maziyar Panahi) #2

I thought this might help:

https://lh4.googleusercontent.com/-f7VJoSB5YbE/U1iB2gYdY1I/AAAAAAAAA7U/iaF3zBG5eTk/s1600/Screenshot+2014-04-24+11.14.03.png

https://lh4.googleusercontent.com/-oPkwRBKWFuQ/U1iBy2yA8fI/AAAAAAAAA7M/9AWIdC7Zx4c/s1600/Screenshot+2014-04-24+11.14.14.png

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2f11960f-84b1-4b07-aa4a-4c1cda543e99%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Radu Gheorghe) #3

Hello,

What happens if you start ES without any plugin? Do you get the same high
CPU load?

If not, then you can try enabling one plugin at a time and see which one is
the cause. Also, make sure that your plugins match your version. For
example, you seem to need the mongodb river to be version 1.7.4 to work
with 1.0.0.

Best regards,
Radu

On Thu, Apr 24, 2014 at 6:15 AM, Maziyar Panahi
sm.shariatpanahi@gmail.comwrote:

I thought this might help:

https://lh4.googleusercontent.com/-f7VJoSB5YbE/U1iB2gYdY1I/AAAAAAAAA7U/iaF3zBG5eTk/s1600/Screenshot+2014-04-24+11.14.03.png

https://lh4.googleusercontent.com/-oPkwRBKWFuQ/U1iBy2yA8fI/AAAAAAAAA7M/9AWIdC7Zx4c/s1600/Screenshot+2014-04-24+11.14.14.png

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2f11960f-84b1-4b07-aa4a-4c1cda543e99%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/2f11960f-84b1-4b07-aa4a-4c1cda543e99%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Performance Monitoring * Log Analytics * Search Analytics
Solr & Elasticsearch Support * http://sematext.com/

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHXA0_0xw0N%2B_buvFMM0t-zhFwrRUb8ssjH5kG7nAQhfmoOAJA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Maziyar Panahi) #4

Hi Radu,

That's what I ended up and once I remove Marvel it wen back to the normal
CPU usage. I still don't know what [management] means though.
I'm guessing since I installed Marvel few months back on 0.9 it may have
been changed and updated for new ES.

I will try to install new Marvel to see how it reacts this time.

Thanks

On Thursday, 24 April 2014 19:35:13 UTC+8, Radu Gheorghe wrote:

Hello,

What happens if you start ES without any plugin? Do you get the same high
CPU load?

If not, then you can try enabling one plugin at a time and see which one
is the cause. Also, make sure that your plugins match your version. For
example, you seem to need the mongodb river to be version 1.7.4 to work
with 1.0.0.

Best regards,
Radu

On Thu, Apr 24, 2014 at 6:15 AM, Maziyar Panahi <sm.shari...@gmail.com<javascript:>

wrote:

I thought this might help:

https://lh4.googleusercontent.com/-f7VJoSB5YbE/U1iB2gYdY1I/AAAAAAAAA7U/iaF3zBG5eTk/s1600/Screenshot+2014-04-24+11.14.03.png

https://lh4.googleusercontent.com/-oPkwRBKWFuQ/U1iBy2yA8fI/AAAAAAAAA7M/9AWIdC7Zx4c/s1600/Screenshot+2014-04-24+11.14.14.png

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2f11960f-84b1-4b07-aa4a-4c1cda543e99%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/2f11960f-84b1-4b07-aa4a-4c1cda543e99%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Performance Monitoring * Log Analytics * Search Analytics
Solr & Elasticsearch Support * http://sematext.com/

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/80e33c22-85c9-48b5-adb7-43f05903c044%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #5