Highlighting in version 2.0.2?


(Jonas) #1

Hello, I have following query:

GET bp/_search
{
"query" : {
"query_string" : {
"query" : "EUR"
}
},
"highlight" : {
"fields": {
"businessData": {}
}
}
}
}

So I expected the EUR sign to be surronded by the tag in my highlight, but I get following response.

{
"took": 19,
"timed_out": false,
"_shards": {
"total": 5,
"successful": 5,
"failed": 0
},
"hits": {
"total": 31,
"max_score": 0.060523164,
"hits": [
{
"_index": "bp",
"_type": "FormatEnvelope",
"_id": "2-1",
"_score": 0.060523164,
"_parent": "2",
"_routing": "2",
"_source": {
"uniqueIdentifier": 2,
"businessData": "\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\tfalse\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\tfalse\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\tfalse\n\t\t\t\n\t\t\t\n\t\t\t\tSystem:Amount2665.130000000000000</System:Amount>\n\t\t\t\tSystem:CurrencyCodeEUR</System:CurrencyCode>\n\t\t\t\n\t\tfalse\n\t\t\t\n\t\t\t1\n\t\t\t\n\t\t\tfalse\n\t\t\t\n\t\t\tfalse\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t1\n\t\t\t\n\t\t\t3\n\t\t\t\n\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t1\n\t\t\t\n\t\t\t\n\t\t\tNone\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\n\t\t\tfalse\n\t\t\t\n\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\n\t\t\t\n\t\t\t\n\t\t\n\t\t\t\t\t\n\t\t\t\t\t\t<primarykey model="Payment" entity="AdditionalCharacteristicsType">\n\t\t\t\t\t\t\t\n\t\t\t\t\t\t\t\t<primarykey model="Message" entity="MessageFormat">\n\t\t\t\t\t\t\t\t\tMT101\n\t\t\t\t\t\t\t\t\n\t\t\t\t\t\t\t\n\t\t\t\t\t\t\tMESSAGE_INDEX\n\t\t\t\t\t\t\n\t\t\t\t\t\n\t\t\t\t\t1\n\t\t\t\t\n\t\t\t\t\n\t\t\t\t\t\n\t\t\t\t\t\n\t\t\t\t\t\n\t\t\t\t\t\t<primarykey model="Payment" entity="AdditionalCharacteristicsType">\n\t\t\t\t\t\t\t\n\t\t\t\t\t\t\t\t<primarykey model="Message" entity="MessageFormat">\n\t\t\t\t\t\t\t\t\tMT101\n\t\t\t\t\t\t\t\t\n\t\t\t\t\t\t\t\n\t\t\t\t\t\t\tMESSAGE_TOTAL\n\t\t\t\t\t\t\n\t\t\t\t\t\n\t\t\t\t\t1\n\t\t\t\t\n\t\t\t\n\t\t\t\n\t\t\t\t\n\t\t\t\n\t\t"
}
},
...

I don't see anything from highlighting. I've looked up bugs and I see highlighting doesn't work properly in version 2.1, But I use 2.0.2.Is tha version also bad or do I do something bad in my query?
thanks


(system) #2