Highlighting not working with synonym filter


(vineeth mohan-2) #1

Steps to reproduce -

Index creation script

  1. Download http://wordnetcode.princeton.edu/3.0/WNprolog-3.0.tar.gz ,
    extract wn_s.pl and place it in config directory.
  2. Create an index using this script -
    https://gist.github.com/Vineeth-Mohan/7118283
  3. ./AboveScript localhost
  4. Index a feed
    curl -XPOST 'http://localhost:9200/events/news' -d ' { "Events" : {
    "Event" : "large forest in large" } }'
  5. Execute this search - https://gist.github.com/Vineeth-Mohan/7118312
  6. Output obtained - https://gist.github.com/Vineeth-Mohan/7118329

Observation - Received "large forest in
large" rather than "large forest in
large" for searching big ( big is present in the synonym file)

Thanks
Vineeth

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #2