Highlighting - not working


(Nayeli Santacruz) #1

Greetings to all
I have the following problem:

I'm doing some tests with facetings

My script is as follows:

the result I get is as follows:

{
"took": 2,
"timed_out": false,
"_shards": {
"total": 5,
"successful": 5,
"failed": 0
},
"hits": {
"total": 2,
"max_score": 1,
"hits": []
},
"facets": {
"title": {
"_type": "terms",
"missing": 0,
"total": 2,
"other": 0,
"terms": [
{
"term": "JavaScript",
"count": 1
},
{
"term": "Java Platform, Standard Edition",
"count": 1
}
]
}
}
}

which is fine, but the problem is that I can not display the "highlighting"

I was expecting a result like the following:

..........
..........
..........

"facets": {
    "title": {
        "_type": "terms",
        "missing": 0,
        "total": 2,
        "other": 0,
        "terms": [
            {
                "term": "<b>Java</b>Script",
                "count": 1
            },
            {
                "term": "<b>Java</b> Platform, Standard Edition",
                "count": 1
            }
        ]
    }
}

..........
..........
..........

Anyone can help me and tell me what I'm doing wrong or what I'm missing,
please

Thank you very much for your attention

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #2

Hey

highlighting does not work inside facet results, but only for search
results (which you set to 0 using the size parameter).

--Alex

On Wed, Sep 18, 2013 at 5:38 PM, Nayeli Santacruz <
nayeli.santacruz2.0@gmail.com> wrote:

Greetings to all
I have the following problem:

I'm doing some tests with facetings

My script is as follows:

https://gist.github.com/nayelisantacruz/6610862

the result I get is as follows:

{
"took": 2,
"timed_out": false,
"_shards": {
"total": 5,
"successful": 5,
"failed": 0
},
"hits": {
"total": 2,
"max_score": 1,
"hits": []
},
"facets": {
"title": {
"_type": "terms",
"missing": 0,
"total": 2,
"other": 0,
"terms": [
{
"term": "JavaScript",
"count": 1
},
{
"term": "Java Platform, Standard Edition",
"count": 1
}
]
}
}
}

which is fine, but the problem is that I can not display the "highlighting"

I was expecting a result like the following:

..........
..........
..........

"facets": {
    "title": {
        "_type": "terms",
        "missing": 0,
        "total": 2,
        "other": 0,
        "terms": [
            {
                "term": "<b>Java</b>Script",
                "count": 1
            },
            {
                "term": "<b>Java</b> Platform, Standard Edition",
                "count": 1
            }
        ]
    }
}

..........
..........
..........

Anyone can help me and tell me what I'm doing wrong or what I'm missing,
please

Thank you very much for your attention

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3