Hosts value I comment , apm-server do not start

Hi All,
I am using centos 7, SElinux disabled, firewall disabled, my elasticsearch and kibana service after I modified for singlehost it is working, I am able to see the status of elasticsearch and kibana OK and running
My environment is as
Kibana version:
7.5.1-1
Elasticsearch version:
7.5.1-1
APM Server version:
7.5.1-1

In apm-server.yml , if I change the value of hosts to any values such as
host: "0.0.0.0:8200"
or
host: "1XX.1X.1.2XX:8200"
or
host: "localhost:8200"

and I restart I apm-server do not start.If I comment host it works

Earlier I had done the same exact setup, but of lower version on Ubuntu, it worked for **host: "0.0.0.0:8200"

Only difference is of the OS and instead of on premise, I am using centos on AWS cloud (security group permissions are all fine]

Requesting guidance and why my apm-server do not start when I change the values of host and why it starts when I comment host

Thanks
Joseph John

Does the apm-server command exit with an error immediately? If so, what is the error? Otherwise, are there error messages in the log file?

If there's nothing obvious there, please copy your apm-server.yml config file somewhere (with any secret_token and passwords removed).

1 Like

Hi Andrew,
thanks.
Like to update exact configuration when I tried with Ubuntu it worked, in centos7 , It is not working
like to add in my centos7 , SELinux is disabled, iptables -F (flushed), no firewall

No I am using Ubuntu and it is working fine, do not know why in CentOS 7 , it is not working
Thanks
Joseph John