How can I change my default data from /var/lib/elasticsearch/ to /opt/elasticsearch?


(Asrozar) #1

I just upgraded from 90.3 (using tar.gz file) to 90.10 using the rpm.

My 90.3 was stored in /opt/elasticsearch, and the /opt is my largest
partition, so I need to change this back if I can. Also, now Kibana is not
looking at the indexes from /opt/elasticsearch, but I assuke once I move
elasticsearch back it will be fine.

Thanks for your help!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8205a467-ac46-44e2-8b37-425ef25031e0%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Asrozar) #2

It looks like its set int the start up script
(-Des.default.path.data=$DATA_DIR) but I cant find where $DATA_DIR is set.
Anyone know where $DATA_DIR is set?

On Wednesday, January 15, 2014 1:51:16 PM UTC-5, avery...@insecure-it.com
wrote:

I just upgraded from 90.3 (using tar.gz file) to 90.10 using the rpm.

My 90.3 was stored in /opt/elasticsearch, and the /opt is my largest
partition, so I need to change this back if I can. Also, now Kibana is not
looking at the indexes from /opt/elasticsearch, but I assuke once I move
elasticsearch back it will be fine.

Thanks for your help!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8bdf375a-b731-4a35-8312-301074d63027%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Brian Yoder) #3

The data directory pathname is stored within the elasticsearch.yml
configuration file.

The path name to the configuration file may be specified passing the
following option to the startup script, where path-to-config is the name
of the directory into which you store your customized elasticsearch.yml
configuration file:

-Des.path.conf=/path-to-config

Brian

On Wednesday, January 15, 2014 2:18:01 PM UTC-5, avery...@insecure-it.com
wrote:

It looks like its set int the start up script
(-Des.default.path.data=$DATA_DIR) but I cant find where $DATA_DIR is set.
Anyone know where $DATA_DIR is set?

On Wednesday, January 15, 2014 1:51:16 PM UTC-5, avery...@insecure-it.comwrote:

I just upgraded from 90.3 (using tar.gz file) to 90.10 using the rpm.

My 90.3 was stored in /opt/elasticsearch, and the /opt is my largest
partition, so I need to change this back if I can. Also, now Kibana is not
looking at the indexes from /opt/elasticsearch, but I assuke once I move
elasticsearch back it will be fine.

Thanks for your help!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bcfbd112-a1b4-41db-984a-eabade3ee1a5%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4