How can I match multimatch with NEST in elasticsearch?

I want to search with RegisterNumber and Title at the same time. But how can I match both at the same time? Also, when I press the space character, I cannot make calls after the space. How can I solve this? Currently searching by title but when I search with registernumber it doesn't see the records. Both are string types.
I tried to do it with a wildcard but I couldn't.

var searchResponse = eClient.Search<GlobalCompany>(s => s.Index(INDEX_NAME)
                  .Query(q => q
                  .MultiMatch(m => m
                            .Fields(f => f
                                .Field(u => u.Title)
                                .Field(u => u.RegisterNumber))

Could you provide a full recreation script as described in About the Elasticsearch category. It will help to better understand what you are doing. Please, try to keep the example as simple as possible.

A full reproduction script is something anyone can copy and paste in Kibana dev console, click on the run button to reproduce your use case. It will help readers to understand, reproduce and if needed fix your problem. It will also most likely help to get a faster answer.

It's better to understand first what is happening without using Nest.

I solved my problem, I have a problem with frontend vue.js. But I still have a problem here. I'm doing the search process, but it doesn't verify the fields after the space character. For example, when I search for John, the record comes up.But when I search for "John Steven", it does not find it even though it is recorded.I do the search by typing in an autocomplete text.

If you need help, please provide a script which describes and reproduces the problem.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.