How do I set tie_breaker parameter to a float value (e.g. 0.1) using MultiMatchQueryBuilder?

Hi,

how do I set tie_breaker parameter to a float value (e.g. 0.1) when
using org.elasticsearch.index.query.MultiMatchQueryBuilder?
MultiMatchQueryBuilder has tieBreaker(Integer) method, but no
tieBreaker(float) method (DisMaxQueryBuilder has tieBreaker(float) method.)
Is this a bug, or is there some mapping from Integer to float?

Thanks,
Jan Kouba

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On Tue, 2013-03-12 at 08:49 -0700, Jan Kouba wrote:

Hi,

how do I set tie_breaker parameter to a float value (e.g. 0.1) when
using org.elasticsearch.index.query.MultiMatchQueryBuilder?
MultiMatchQueryBuilder has tieBreaker(Integer) method, but no
tieBreaker(float) method (DisMaxQueryBuilder has tieBreaker(float)
method.) Is this a bug, or is there some mapping from Integer to
float?

That's a bug - I've pushed a fix to master

clint

Thanks,
Jan Kouba

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thank you!

Any chance this fix will be included in 0.20 branch?

On Wednesday, March 13, 2013 1:47:19 PM UTC+1, Clinton Gormley wrote:

That's a bug - I've pushed a fix to master

https://github.com/elasticsearch/elasticsearch/issues/2772

clint

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.