How should I configure network.host to bind to an aws elastic IP


(Robin Southgate) #1

I'm trying to set up an elasticsearch service to bind to the elastic IP assigned to the instance it's running on - but can't figure out the correct way.

I've tried:

network.host = [local, "52.xxx.xxx.xxx"]
network.host = 52.xxx.xxx.xxx
network.host = 0.0.0.0

When starting with the elastic IP the service throws an unable to bind exception on restart and closes. When starting with 0.0.0.0 it stasrts but binds to the internal IP of the instance 10.0.0.x

So what should I be setting this to to corretly bind to the external IP?


(Mark Walkom) #2

Is the IP assigned to an interface on the host?


(Robin Southgate) #3

No I think there is a NAT layer since the instance is inside a VPC so en0 is bound to 10.0.0.x and somewhere outside AWS translates the external IP to the internal IP


(Mark Walkom) #4

You can't bind to an IP that doesn't exist on a local interface.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.