How to configure proxy setting for s3 repository plugins


(Bharat Parmar) #1

I have configured below setting

echo "proxy.elasticsearch.internal" | ./elasticsearch-keystore add --stdin s3.client.default.proxy.host
echo "3128" | ./elasticsearch-keystore add --stdin s3.client.default.proxy.port

i am getting below mentioned error
Caused by: org.apache.http.conn.ConnectTimeoutException: Connect to <bucket_name>.s3.amazonaws.com:443 [<bucket_name>.s3.amazonaws.com/52.219.62.40] failed: connect timed out


(Thiago Souza) #2

proxy.host and proxy.port are not secure settings so they can't be stored in keystore and needs to be configured in the repository settings directly through the API.

Only settings marked with (Secure) can be stored in keystore. Refer to this https://www.elastic.co/guide/en/elasticsearch/plugins/6.3/repository-s3-client.html for more information


(Bharat Parmar) #3

can i configure proxy as below api request
PUT _snapshot/my_s3_repository
{
"type": "s3",
"settings": {
"bucket": "my_bucket",
client: {
proxy: {
host: <PROXY_IP>,
port: <PROXY_PORT>
}
}
}
}


(Thiago Souza) #4

Sorry, my mistake here. Actually, you need to add the following to elasticsearch.yml (not using the API as I stated, sorry for this):

s3.client.default.proxy.host: <proxy_ip>
s3.client.default.proxy.port: <proxy_port>

(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.