How to configure the THESPIAN_BASE_IPADDR when encounter 'ActorAddr-(T|:1900) is not a valid ActorSystem admin'

I am a new user of Esrally, currently I have created my custom track in order to benchmark the elastic cloud in azure

when I try the below command, the actor system can not be started

esrally race --track=percolator --target-hosts=$domainOfEsCloud --pipeline=benchmark-only --client-options="use_ssl:true,verify_certs:true,timeout:600,basic_auth_user:'$name',basic_auth_password:'$password'"

Error message:

2023-06-24 00:15:10,175 -not-actor-/PID:2964 esrally.rally INFO Actor system already running locally? [False]
2023-06-24 00:15:10,175 -not-actor-/PID:2964 INFO Starting actor system with system base [multiprocTCPBase] and capabilities [{'coordinator': True, 'ip': '', 'Convention Address.IPv4': ''}].
2023-06-24 00:15:10,222 -not-actor-/PID:2964 root WARNING Unable to get address info for address (2, 2, 17, 0): <class 'socket.gaierror'> [Errno 8] nodename nor servname provided, or not known
2023-06-24 00:15:10,222 -not-actor-/PID:2964 root WARNING Unable to get address info for address (2, 2, 17, 1): <class 'socket.gaierror'> [Errno 8] nodename nor servname provided, or not known
2023-06-24 00:15:10,246 -not-actor-/PID:2969 root INFO ++++ Actor System gen (3, 10) started, admin @ ActorAddr-(T|:1900)
2023-06-24 00:15:15,246 -not-actor-/PID:2964 ERROR Could not initialize internal actor system.
Traceback (most recent call last):
File "/usr/local/lib/python3.11/site-packages/esrally/", line 263, in bootstrap_actor_system
return thespian.actors.ActorSystem(system_base, logDefs=log.load_configuration(), capabilities=capabilities)
File "/usr/local/lib/python3.11/site-packages/thespian/", line 635, in init
systemBase = self._startupActorSys(
File "/usr/local/lib/python3.11/site-packages/thespian/", line 676, in _startupActorSys
systemBase = sbc(self, logDefs=logDefs)
File "/usr/local/lib/python3.11/site-packages/thespian/system/", line 28, in init
super(ActorSystemBase, self).init(system, logDefs)
File "/usr/local/lib/python3.11/site-packages/thespian/system/", line 86, in init
super(multiprocessCommon, self).init(system, logDefs)
File "/usr/local/lib/python3.11/site-packages/thespian/system/", line 326, in init
File "/usr/local/lib/python3.11/site-packages/thespian/system/", line 114, in _startAdmin
raise InvalidActorAddress(adminAddr,
thespian.actors.InvalidActorAddress: ActorAddr-(T|:1900) is not a valid ActorSystem admin

My environment needs to set vpn to get access to github and es cloud resources, so I do the below settings according to direction in

  1. configuration
    export http_proxy=$my_proxy_address
    git config --global http.proxy $http_proxy

and I can run the command successfully ------- git clone GitHub - elastic/rally-tracks: Track specifications for the Elasticsearch benchmarking tool Rally

  1. for the issue 'nodename nor servname provided, or not known'
    I have configed in /etc/hosts as my_hostname, but this method will lose efficiency when I open VPN (can only be used to do the local test)

  2. following the troubleshooting here, I can see another solution to set THESPIAN_BASE_IPADDR, can anyone help how can I set this variable and set to what ip address


Thanks for your interest in Rally!

It seems to me that setting export THESPIAN_BASE_IPADDR= should work. Alternatively, consider using the offline mode: Offline Usage - Rally 2.8.0 documentation.

Thanks @Quentin_Pradet , it works

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.