How to configure with version parameter


(porin poporin) #1

I have a question about ”backwards compatibility” in bellow page.
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/analysis.html

I would like to know how to configure with version parameter.

Please help me.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ac9047fd-f87c-4ce6-b543-1889a69c2e35%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Rafi Aroch) #2

Hi Porin,

I never tried this configuration, but the answer is written in the bottom
of the link you added:

All analyzers, tokenizers, and token filters can be configured with a

version parameter to control which Lucene version behavior they should
use. Possible values are: 3.0 - 3.6, 4.0 - 4.3 (the highest version
number is the default option).

For example, the tokenizer part would look like:

tokenizer :
myTokenizer1 :
type : standard
max_token_length : 900

  •            version: 4.0*
    

Hope that helps,

Rafi

On Tuesday, July 1, 2014 11:16:40 AM UTC+3, porin poporin wrote:

I have a question about ”backwards compatibility” in bellow page.

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/analysis.html

I would like to know how to configure with version parameter.

Please help me.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3917609f-f13b-472c-bc5d-88f9ba9ecebb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(porin poporin) #3

Hi Rafi

Thank you for quick response.

I tried to add 1 line 'index.analysis.filter.myTokenFilter.version: 3.0' in
elasticsearch.yml and reboot ES.
But the version parameter is not reflected.

I confirm setting with this curl command "curl -s
localhost:9200/hoge2/_settings?pretty=1".

The response is bellow.


{
"hoge2" : {
"settings" : {
"index" : {
"number_of_replicas" : "1",
"number_of_shards" : "5",
"uuid" : "CfJDEyeZSVyLAKuSs37GLA",
"version" : {
"created" : "1020199"
}
}
}
}
}

I don't know how to change configuration...

regards
porin

2014年7月1日火曜日 17時16分40秒 UTC+9 porin poporin:

I have a question about ”backwards compatibility” in bellow page.

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/analysis.html

I would like to know how to configure with version parameter.

Please help me.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6bbb3dac-67b3-4785-825a-502ce2c12250%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4