How to connect Sybase Sql Anywhere 9 with logstash

I'm new to using Elasticsearh components, and I'm having trouble connecting the Sybase SqlAnywhere database to LogStash. Below the configuration file to connect LogStash to SqlAnywhere is showing an error, I have already made several attempts and I cannot configure correctly. Which jdbc drive should I use, where can I download it and how to configure it.
Can someone help me please?

input
{
jdbc
{
jdbc_connection_string => "jdbc:sqlanywhere://192.168.0.60:2638/dbcash"
jdbc_user => "dba"
jdbc_password => "sql"
jdbc_validate_connection => true
jdbc_driver_library => "C:/Program Files (x86)/Sybase/SQL Anywhere 9/java/jconn3-6.0.jar"
#jdbc_driver_class => "com.sybase.jdbc3.jdbc.SybDriver"
jdbc_driver_class => "com.sybase.jdbc3.jdbc.SybDataSource"
statement => "SELECT Codigo, Nome, NomerED Endereco, Numero, Bairro, Cidade, UF, Cep, Fone, email FROM ACADCLIE"
}
}
output
{
elasticsearch
{
hosts => ["http://192.168.0.250:9200"]
index => "bancodataminner"
document_type => "clientes"
document_id => "%{codigo}"
}
}

"Using bundled JDK: ""
Sending Logstash logs to C:/LogStash/logstash-7.11.1/logs which is now configured via log4j2.properties
[2021-03-25T10:19:57,562][INFO ][logstash.runner ] Starting Logstash {"logstash.version"=>"7.11.1", "jruby.version"=>"jruby 9.2.13.0 (2.5.7) 2020-08-03 9a89c94bcc OpenJDK 64-Bit Server VM 11.0.8+10 on 11.0.8+10 +indy +jit [mswin32-x86_64]"}
[2021-03-25T10:19:57,812][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2021-03-25T10:19:59,703][INFO ][org.reflections.Reflections] Reflections took 31 ms to scan 1 urls, producing 23 keys and 47 values
[2021-03-25T10:20:00,046][WARN ][logstash.outputs.elasticsearch] You are using a deprecated config setting "document_type" set in elasticsearch. Deprecated settings will continue to work, but are scheduled for removal from logstash in the future. Document types are being deprecated in Elasticsearch 6.0, and removed entirely in 7.0. You should avoid this feature If you have any questions about this, please visit the #logstash channel on freenode irc. {:name=>"document_type", :plugin=><LogStash::Outputs::ElasticSearch index=>"bancodataminner", id=>"11b000a57e0f612c63b441fb58eee5c92bb332434afd1220815b98ba91a3fee6", document_id=>"%{codigo}", hosts=>[http://192.168.0.250:9200], document_type=>"clientes", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>"plain_de8d8f91-ae4a-4bd9-9718-820743704ac0", enable_metric=>true, charset=>"UTF-8">, workers=>1, ssl_certificate_verification=>true, sniffing=>false, sniffing_delay=>5, timeout=>60, pool_max=>1000, pool_max_per_route=>100, resurrect_delay=>5, validate_after_inactivity=>10000, http_compression=>false, retry_initial_interval=>2, retry_max_interval=>64, action=>"index", manage_template=>true, template_overwrite=>false, doc_as_upsert=>false, script_type=>"inline", script_lang=>"painless", script_var_name=>"event", scripted_upsert=>false, retry_on_conflict=>1, ilm_enabled=>"auto", ilm_pattern=>"{now/d}-000001", ilm_policy=>"logstash-policy">}
[2021-03-25T10:20:00,453][INFO ][logstash.outputs.elasticsearch][main] Elasticsearch pool URLs updated {:changes=>{:removed=>, :added=>[http://192.168.0.250:9200/]}}
[2021-03-25T10:20:00,640][WARN ][logstash.outputs.elasticsearch][main] Restored connection to ES instance {:url=>"http://192.168.0.250:9200/"}
[2021-03-25T10:20:00,703][INFO ][logstash.outputs.elasticsearch][main] ES Output version determined {:es_version=>7}
[2021-03-25T10:20:00,703][WARN ][logstash.outputs.elasticsearch][main] Detected a 6.x and above cluster: the type event field won't be used to determine the document _type {:es_version=>7}
[2021-03-25T10:20:00,750][INFO ][logstash.outputs.elasticsearch][main] New Elasticsearch output {:class=>"LogStash::Outputs::ElasticSearch", :hosts=>["http://192.168.0.250:9200"]}
[2021-03-25T10:20:00,843][INFO ][logstash.javapipeline ][main] Starting pipeline {:pipeline_id=>"main", "pipeline.workers"=>2, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>50, "pipeline.max_inflight"=>250, "pipeline.sources"=>["E:/AtuDM/conf/lerclientes.conf"], :thread=>"#<Thread:0x68671072 run>"}
[2021-03-25T10:20:00,828][INFO ][logstash.outputs.elasticsearch][main] Using a default mapping template {:es_version=>7, :ecs_compatibility=>:disabled}
[2021-03-25T10:20:00,953][INFO ][logstash.outputs.elasticsearch][main] Attempting to install template {:manage_template=>{"index_patterns"=>"logstash-", "version"=>60001, "settings"=>{"index.refresh_interval"=>"5s", "number_of_shards"=>1}, "mappings"=>{"dynamic_templates"=>[{"message_field"=>{"path_match"=>"message", "match_mapping_type"=>"string", "mapping"=>{"type"=>"text", "norms"=>false}}}, {"string_fields"=>{"match"=>"", "match_mapping_type"=>"string", "mapping"=>{"type"=>"text", "norms"=>false, "fields"=>{"keyword"=>{"type"=>"keyword", "ignore_above"=>256}}}}}], "properties"=>{"@timestamp"=>{"type"=>"date"}, "@version"=>{"type"=>"keyword"}, "geoip"=>{"dynamic"=>true, "properties"=>{"ip"=>{"type"=>"ip"}, "location"=>{"type"=>"geo_point"}, "latitude"=>{"type"=>"half_float"}, "longitude"=>{"type"=>"half_float"}}}}}}}
[2021-03-25T10:20:01,750][INFO ][logstash.javapipeline ][main] Pipeline Java execution initialization time {"seconds"=>0.91}
[2021-03-25T10:20:01,906][INFO ][logstash.javapipeline ][main] Pipeline started {"pipeline.id"=>"main"}
[2021-03-25T10:20:01,953][INFO ][logstash.agent ] Pipelines running {:count=>1, :running_pipelines=>[:main], :non_running_pipelines=>}
[2021-03-25T10:20:02,500][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}
[2021-03-25T10:20:02,906][ERROR][logstash.inputs.jdbc ][main][fd43507d46fd1e1fa8d352be382879f9b3c7bd215ea95f723b3a0d506ccdd58f] Unable to connect to database. Tried 1 times {:error_message=>"NoMethodError: undefined method new' for #<Array:0x91b8fab>"} [2021-03-25T10:20:02,937][ERROR][logstash.javapipeline ][main][fd43507d46fd1e1fa8d352be382879f9b3c7bd215ea95f723b3a0d506ccdd58f] A plugin had an unrecoverable error. Will abase. Tried 1 times {:error_message=>"NoMethodError: undefined method new' for #Array:0x91b8fab"}
[2021-03-25T10:20:08,156][ERROR][logstash.javapipeline ][main][fd43507d46fd1e1fa8d352be382879f9b3c7bd215ea95f723b3a0d506ccdd58f] A plugin had an unrecoverable error. Will

Welcome!

Please format your code, logs or configuration files using </> icon as explained in this guide and not the citation button. It will make your post more readable.

Or use markdown style like:

```
CODE
```

This is the icon to use if you are not using markdown format:

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.
Please update your post.

I'm also moving your post to #elastic-stack:logstash.