How to Disable allocation awareness attributes in indices level

When allocation-awareness set to zone. It make primary and replicas shard must split into different zone.
When we need make cluster how-warm or shrink , we need move all shards which is warm indices into one zone. but we get error. As explain:

"reason": NO(there are too many copies of the shard allocated to nodes with attribute [zone], there are [2] total configured shard copies for this shard id and [2] total attribute values, expected the allocated shard count per attribute [2] to be less than or equal to the upper bound of the required number of shards per attribute [1])

How to Disable allocation.awareness.attributes in indices level?

I check the code , i can only make allocation-awareness to EMPTY, but it is not a good idea.

Use shard allocation filtering for hot an warm zone assignment, not shard allocation awareness.

Thanks for replying.
Shard allocation filtering can be a indices level, but shard allocation awareness is cluster level.
But how to make some indices use allocation awareness

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.