How to disable attempts to connect to the package registry?


We are operating an Elastic stack in an environment that is intentionally unable to access the outside world/internet.
When we browse to our Kibana dashboards, we see that our browsers are trying to fetch /api/fleet/epm/packages?experimental=true, which times out after a while with errors like this:

"Error connecting to package registry: request to failed, reason: connect ENETUNREACH"

It seems that every time the browser calls the /api/fleet/epm/packages?experimental=true endpoint the server tries to fetch something from which will never work in our environment.

Is there any way to disable those checks?
It is visually annoying and will (by design) never succeed :slight_smile:


Hi, it sounds like you are not using the fleet plugin (Ingest Manager) in your environment. Why not just turn off the plugin in kibana.yml?

xpack.fleet.enabled: false

If you are using Ingest Manager, you can track this issue to find when a self-managed package registry will be supported: Provide self-managed package-registry that backs integrations UI · Issue #1178 · elastic/integrations · GitHub

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.