How to disable shutdown API?

Hello,

I'm using FOQ elastica bundle and I'm trying to disable shutdown API for
security reasons.
According to this link
http://www.elasticsearch.org/guide/reference/api/admin-cluster-nodes-shutdown/,
you just need to add this line: action.disable_shutdown in the node
configuration. So here is my elasticsearch.yml structure:
foq_elastica:
clients:
search1:
host: %elasticsearch-server%
port: %elasticsearch-port%

default_client: search1

indexes:
    website:
        client: search1
        settings:
            index:
                analysis:
                    analyzer: ...
                    filter: ...
            types: ...         

I've tried to put "node: action.disable_shutdown" in the "settings"
namespace but it does not work I'm still able to shutdown ES.
I have no idea where to put this code so if someone has an idea that would
be great. And also, I restart and populate each time I made a modification.
Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You just need to add action.disable_shutdown : true as is in the
elasticsearch.yml (don't put it in any namespace) and then restart the node.

On 29 May 2013 17:41, Damien damien.soulard@gmail.com wrote:

Hello,

I'm using FOQ elastica bundle and I'm trying to disable shutdown API for
security reasons.
According to this link
http://www.elasticsearch.org/guide/reference/api/admin-cluster-nodes-shutdown/,
you just need to add this line: action.disable_shutdown in the node
configuration. So here is my elasticsearch.yml structure:
foq_elastica:
clients:
search1:
host: %elasticsearch-server%
port: %elasticsearch-port%

default_client: search1

indexes:
    website:
        client: search1
        settings:
            index:
                analysis:
                    analyzer: ...
                    filter: ...
            types: ...

I've tried to put "node: action.disable_shutdown" in the "settings"
namespace but it does not work I'm still able to shutdown ES.
I have no idea where to put this code so if someone has an idea that would
be great. And also, I restart and populate each time I made a modification.
Thanks!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks for the answer but that doesn't work.
I've tried to put it before foq_elastica, or just after. I've also tried in
settings namespace. I've made a "service elasticsearch restart" and a
"populate".
But I can still shutdown elasticsearch with this command
curl -XPOST 'http://localhost:9200/_shutdown'

Le jeudi 30 mai 2013 03:15:05 UTC-4, Martijn v Groningen a écrit :

You just need to add action.disable_shutdown : true as is in the
elasticsearch.yml (don't put it in any namespace) and then restart the node.

On 29 May 2013 17:41, Damien <damien....@gmail.com <javascript:>> wrote:

Hello,

I'm using FOQ elastica bundle and I'm trying to disable shutdown API for
security reasons.
According to this link
http://www.elasticsearch.org/guide/reference/api/admin-cluster-nodes-shutdown/,
you just need to add this line: action.disable_shutdown in the node
configuration. So here is my elasticsearch.yml structure:
foq_elastica:
clients:
search1:
host: %elasticsearch-server%
port: %elasticsearch-port%

default_client: search1

indexes:
    website:
        client: search1
        settings:
            index:
                analysis:
                    analyzer: ...
                    filter: ...
            types: ...         

I've tried to put "node: action.disable_shutdown" in the "settings"
namespace but it does not work I'm still able to shutdown ES.
I have no idea where to put this code so if someone has an idea that
would be great. And also, I restart and populate each time I made a
modification.
Thanks!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Can you try to add a space before 'action.disable_shutdown : true' in elasticsearch.yml file?

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 30 mai 2013 à 17:21, Damien damien.soulard@gmail.com a écrit :

Thanks for the answer but that doesn't work.
I've tried to put it before foq_elastica, or just after. I've also tried in settings namespace. I've made a "service elasticsearch restart" and a "populate".
But I can still shutdown elasticsearch with this command
curl -XPOST 'http://localhost:9200/_shutdown'

Le jeudi 30 mai 2013 03:15:05 UTC-4, Martijn v Groningen a écrit :

You just need to add action.disable_shutdown : true as is in the elasticsearch.yml (don't put it in any namespace) and then restart the node.

On 29 May 2013 17:41, Damien damien....@gmail.com wrote:

Hello,

I'm using FOQ elastica bundle and I'm trying to disable shutdown API for security reasons.
According to this link http://www.elasticsearch.org/guide/reference/api/admin-cluster-nodes-shutdown/, you just need to add this line: action.disable_shutdown in the node configuration. So here is my elasticsearch.yml structure:
foq_elastica:
clients:
search1:
host: %elasticsearch-server%
port: %elasticsearch-port%

default_client: search1

indexes:
    website:
        client: search1
        settings:
            index:
                analysis:
                    analyzer: ...
                    filter: ...
            types: ...         

I've tried to put "node: action.disable_shutdown" in the "settings" namespace but it does not work I'm still able to shutdown ES.
I have no idea where to put this code so if someone has an idea that would be great. And also, I restart and populate each time I made a modification.
Thanks!

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Sorry but I don't understand what you mean. Adding a space like this
'action.disable_shutdown : true'?
And where do you think I should put this line in my elasticsearch.yml?
Thanks for your help.

Le jeudi 30 mai 2013 12:12:52 UTC-4, David Pilato a écrit :

Can you try to add a space before 'action.disable_shutdown : true' in
elasticsearch.yml file?

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 30 mai 2013 à 17:21, Damien <damien....@gmail.com <javascript:>> a
écrit :

Thanks for the answer but that doesn't work.
I've tried to put it before foq_elastica, or just after. I've also tried
in settings namespace. I've made a "service elasticsearch restart" and a
"populate".
But I can still shutdown elasticsearch with this command
curl -XPOST 'http://localhost:9200/_shutdown'

Le jeudi 30 mai 2013 03:15:05 UTC-4, Martijn v Groningen a écrit :

You just need to add action.disable_shutdown : true as is in the
elasticsearch.yml (don't put it in any namespace) and then restart the node.

On 29 May 2013 17:41, Damien damien....@gmail.com wrote:

Hello,

I'm using FOQ elastica bundle and I'm trying to disable shutdown API for
security reasons.
According to this link
http://www.elasticsearch.org/guide/reference/api/admin-cluster-nodes-shutdown/,
you just need to add this line: action.disable_shutdown in the node
configuration. So here is my elasticsearch.yml structure:
foq_elastica:
clients:
search1:
host: %elasticsearch-server%
port: %elasticsearch-port%

default_client: search1

indexes:
    website:
        client: search1
        settings:
            index:
                analysis:
                    analyzer: ...
                    filter: ...
            types: ...         

I've tried to put "node: action.disable_shutdown" in the "settings"
namespace but it does not work I'm still able to shutdown ES.
I have no idea where to put this code so if someone has an idea that
would be great. And also, I restart and populate each time I made a
modification.
Thanks!

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Yes. That's it.
You can put that line wherever you want.

Does it work?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 30 mai 2013 à 21:19, Damien damien.soulard@gmail.com a écrit :

Sorry but I don't understand what you mean. Adding a space like this 'action.disable_shutdown : true'?
And where do you think I should put this line in my elasticsearch.yml?
Thanks for your help.

Le jeudi 30 mai 2013 12:12:52 UTC-4, David Pilato a écrit :

Can you try to add a space before 'action.disable_shutdown : true' in elasticsearch.yml file?

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 30 mai 2013 à 17:21, Damien damien....@gmail.com a écrit :

Thanks for the answer but that doesn't work.
I've tried to put it before foq_elastica, or just after. I've also tried in settings namespace. I've made a "service elasticsearch restart" and a "populate".
But I can still shutdown elasticsearch with this command
curl -XPOST 'http://localhost:9200/_shutdown'

Le jeudi 30 mai 2013 03:15:05 UTC-4, Martijn v Groningen a écrit :

You just need to add action.disable_shutdown : true as is in the elasticsearch.yml (don't put it in any namespace) and then restart the node.

On 29 May 2013 17:41, Damien damien....@gmail.com wrote:

Hello,

I'm using FOQ elastica bundle and I'm trying to disable shutdown API for security reasons.
According to this link http://www.elasticsearch.org/guide/reference/api/admin-cluster-nodes-shutdown/, you just need to add this line: action.disable_shutdown in the node configuration. So here is my elasticsearch.yml structure:
foq_elastica:
clients:
search1:
host: %elasticsearch-server%
port: %elasticsearch-port%

default_client: search1

indexes:
    website:
        client: search1
        settings:
            index:
                analysis:
                    analyzer: ...
                    filter: ...
            types: ...         

I've tried to put "node: action.disable_shutdown" in the "settings" namespace but it does not work I'm still able to shutdown ES.
I have no idea where to put this code so if someone has an idea that would be great. And also, I restart and populate each time I made a modification.
Thanks!

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

No. If I put a space before the command, I think it breaks yml structure
with the 4 spaces indentation.
If I put it before foq_elastica, when I populate it says "There is no
extension able to load the configuration for "action.disable_shutdown""
If I put just after foq_elastica, it says "Unrecognized options
"action.disable_shutdown" under "foq_elastica""
There is only no error when I put it in the "settings" namespace but it's
not working either, I can still shutdown ES.

Le jeudi 30 mai 2013 17:22:02 UTC-4, David Pilato a écrit :

Yes. That's it.
You can put that line wherever you want.

Does it work?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 30 mai 2013 à 21:19, Damien <damien....@gmail.com <javascript:>> a
écrit :

Sorry but I don't understand what you mean. Adding a space like this
'action.disable_shutdown : true'?
And where do you think I should put this line in my elasticsearch.yml?
Thanks for your help.

Le jeudi 30 mai 2013 12:12:52 UTC-4, David Pilato a écrit :

Can you try to add a space before 'action.disable_shutdown : true' in
elasticsearch.yml file?

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 30 mai 2013 à 17:21, Damien damien....@gmail.com a écrit :

Thanks for the answer but that doesn't work.
I've tried to put it before foq_elastica, or just after. I've also tried
in settings namespace. I've made a "service elasticsearch restart" and a
"populate".
But I can still shutdown elasticsearch with this command
curl -XPOST 'http://localhost:9200/_shutdown'

Le jeudi 30 mai 2013 03:15:05 UTC-4, Martijn v Groningen a écrit :

You just need to add action.disable_shutdown : true as is in the
elasticsearch.yml (don't put it in any namespace) and then restart the node.

On 29 May 2013 17:41, Damien damien....@gmail.com wrote:

Hello,

I'm using FOQ elastica bundle and I'm trying to disable shutdown API
for security reasons.
According to this link
http://www.elasticsearch.org/guide/reference/api/admin-cluster-nodes-shutdown/,
you just need to add this line: action.disable_shutdown in the node
configuration. So here is my elasticsearch.yml structure:
foq_elastica:
clients:
search1:
host: %elasticsearch-server%
port: %elasticsearch-port%

default_client: search1

indexes:
    website:
        client: search1
        settings:
            index:
                analysis:
                    analyzer: ...
                    filter: ...
            types: ...         

I've tried to put "node: action.disable_shutdown" in the "settings"
namespace but it does not work I'm still able to shutdown ES.
I have no idea where to put this code so if someone has an idea that
would be great. And also, I restart and populate each time I made a
modification.
Thanks!

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Ok I fixed it.
Sorry but it was entirely my fault. I was modifying the wrong
elasticsearch.yml file. I was modifying the one in my project but it's not
this one.
The right one is the elasticsearch.yml in /etc/elasticsearch.
I feel bad spending so much time for that, sorry guys!
Thanks for your time.

Le jeudi 30 mai 2013 17:46:46 UTC-4, Damien a écrit :

No. If I put a space before the command, I think it breaks yml structure
with the 4 spaces indentation.
If I put it before foq_elastica, when I populate it says "There is no
extension able to load the configuration for "action.disable_shutdown""
If I put just after foq_elastica, it says "Unrecognized options
"action.disable_shutdown" under "foq_elastica""
There is only no error when I put it in the "settings" namespace but it's
not working either, I can still shutdown ES.

Le jeudi 30 mai 2013 17:22:02 UTC-4, David Pilato a écrit :

Yes. That's it.
You can put that line wherever you want.

Does it work?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 30 mai 2013 à 21:19, Damien damien....@gmail.com a écrit :

Sorry but I don't understand what you mean. Adding a space like this
'action.disable_shutdown : true'?
And where do you think I should put this line in my elasticsearch.yml?
Thanks for your help.

Le jeudi 30 mai 2013 12:12:52 UTC-4, David Pilato a écrit :

Can you try to add a space before 'action.disable_shutdown : true' in
elasticsearch.yml file?

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 30 mai 2013 à 17:21, Damien damien....@gmail.com a écrit :

Thanks for the answer but that doesn't work.
I've tried to put it before foq_elastica, or just after. I've also tried
in settings namespace. I've made a "service elasticsearch restart" and a
"populate".
But I can still shutdown elasticsearch with this command
curl -XPOST 'http://localhost:9200/_shutdown'

Le jeudi 30 mai 2013 03:15:05 UTC-4, Martijn v Groningen a écrit :

You just need to add action.disable_shutdown : true as is in the
elasticsearch.yml (don't put it in any namespace) and then restart the node.

On 29 May 2013 17:41, Damien damien....@gmail.com wrote:

Hello,

I'm using FOQ elastica bundle and I'm trying to disable shutdown API
for security reasons.
According to this link
http://www.elasticsearch.org/guide/reference/api/admin-cluster-nodes-shutdown/,
you just need to add this line: action.disable_shutdown in the node
configuration. So here is my elasticsearch.yml structure:
foq_elastica:
clients:
search1:
host: %elasticsearch-server%
port: %elasticsearch-port%

default_client: search1

indexes:
    website:
        client: search1
        settings:
            index:
                analysis:
                    analyzer: ...
                    filter: ...
            types: ...         

I've tried to put "node: action.disable_shutdown" in the "settings"
namespace but it does not work I'm still able to shutdown ES.
I have no idea where to put this code so if someone has an idea that
would be great. And also, I restart and populate each time I made a
modification.
Thanks!

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.