How to disable stopwords handling


(Colin Surprenant) #1

Hi,

I would like to disable the stopwords handling to actually index all
stopwords from my documents.

Should this config work?

index :
analysis :
analyzer :
default :
type : standard
stopwords : []

It does not seems to work in my tests - keeps using the default stopwords list.

What would be the correct way configure this? Workaround is to put a
single dummy stopword in the list...

Thanks,
Colin


(Shay Banon) #2

It should work, but currently there is a bug that if you specify empty
array, it will use the default set of stop words. For now, you can specify a
single really ridiculous stop word. I have just fixed it in master:
http://github.com/elasticsearch/elasticsearch/issues/issue/230.

-shay.banon

On Thu, Jun 17, 2010 at 11:55 PM, Colin Surprenant <
colin.surprenant@gmail.com> wrote:

Hi,

I would like to disable the stopwords handling to actually index all
stopwords from my documents.

Should this config work?

index :
analysis :
analyzer :
default :
type : standard
stopwords : []

It does not seems to work in my tests - keeps using the default stopwords
list.

What would be the correct way configure this? Workaround is to put a
single dummy stopword in the list...

Thanks,
Colin


(system) #3