How to eliminate swapping of logstash container

elasticsearch / logstash / kibana oss 6.2.4 running as docker containers in one physical host.
Already set vm.swappiness=1 on the host. But swappiness still happening.

I tried following setting for elasticsearch nodes, but swapping still happening on elasticsearch nodes. Not sure what setting I can try on logstash?

  - bootstrap.memory_lock=true

    soft: -1
    hard: -1


If I restart all containers, the host will reclaim all the free swap space initially. But host gradually lost its swap space.
If I increase JVM heap size to 8GB, it slows down the rate of disappearing swap space.
I am using daily index and one log file has 25GB data/day. What is the idea heap size for JVM?


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.