How to fix setting "indices.recovery.max_bytes_per_sec" in splitted cluster?


#1

Hi guys!

I have a cluster (v5.6.4) with nodes in most default settings, and this settings works in cluster

9 nodes [all master eligible, ingest: (default=true), client: (default=true) and data: (default=true) ]

and with this config settings in all too:

cluster.routing.allocation.node_initial_primaries_recoveries: 2
cluster.routing.allocation.node_concurrent_recoveries: 2
indices.recovery.max_bytes_per_sec: 10mb

But, in my new cluster env (v5.6.16) with master, client, data and kibana in separated instances this configs are not to be applied.

I put the config in all nodes, but nothing...

What is wrong? Only dynamic?


(Nhat Nguyen) #2

Can you provide your cluster setting including the defaults? GET /_cluster/settings?include_defaults=true?


#3

http://dontpad.com/how-to-fix-setting-indices-recovery-max-bytes-per-sec-in-splitted-cluster


(Nhat Nguyen) #4

@rmsys The content was truncated. Can you make it as a gist?


#5

Hey Nhat,

Put in this link

http://dontpad.com/how-to-fix-setting-indices-recovery-max-bytes-per-sec-in-splitted-cluster


#6

This link it's ok?


#7

bump