How to "ignore" dynamic fields not matching any "dynamic_templates"?


(Drew) #1

Hey Guys,

In my mapping, I set 'dynamic' to 'true' and I have a few 'dynamic_templates' that based on the name of the fields map them to different types. How can I ignore and not index fields that don't match any of the templates? I tried adding an "ignoredFields" dynamic template like below to ignore the fields but it doesn't seem to be working and all undefined fields still get mapped.

{
"ignored": {
"match": "*",
"mapping": {
"enabled": false
}
}
}

Thanks,

Drew

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/58182A69-1A91-4039-865A-F05EDBE22B89%40venarc.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2