How to increase number of fields in index template?


(Vitaly) #1

I added total_fields.limit into my default logstash index template:

  "settings" : {
       "number_of_shards" : 1,
       "number_of_replicas": 0,
       "index.mapping.total_fields.limit" : "2000"
                 }

But when I check the new index settings (GET _settings call), I don't see total_fields property updated:

"settings" : {
  "index" : {
    "creation_date" : "1520413126830",
    "number_of_shards" : "1",
    "number_of_replicas" : "0",
    "uuid" : "UE7a0kuUS5mjhcHieAomTw",
    "version" : {
      "created" : "5060399"
    }

Any ideas?
Thank you,
Vitaly
PS: I'm with 5.6 version.


(Vitaly) #2

Answering to myself - because I tried to update existing template (and not add the new one), I should delete the current template first.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.