How to install ELK in a raspberry PI


Im trying to install ELK in a raspberry PI and i have little success by now. I have installed the package via apt-get install, and the java version is not compatible. I have downgraded java to jre8 and i have problems now with snakeyaml.

I have also tried to search for an ELK docker image for ARM and i have found nothing

Has anybody managed to do it? Can you help?


We currently only support 64bit ARM so you need to be running a V4 RPi.

1 Like

yep, i have a pi4. Where can i download the app from?

I’m trying to use the rpm aarch 64, is this correct? It gives me an error when installing

Hi @warkolm

Im unable to install it. I have tried both the rpm and deb files and i have this

package architecture (arm64) does not match system (armhf)

I have added the new architecture to dpkg and i can bypass this error

sudo dpkg --add-architecture arm64

But im having issues with libc6 now

sudo dpkg -i elasticsearch-7.9.1-arm64.deb
Selecting previously unselected package elasticsearch:arm64.
(Reading database ... 100403 files and directories currently installed.)
Preparing to unpack elasticsearch-7.9.1-arm64.deb ...
Unpacking elasticsearch:arm64 (7.9.1) ...
dpkg: dependency problems prevent configuration of elasticsearch:arm64:
elasticsearch:arm64 depends on libc6.

Any idea how can i fix it?


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.