How to make a query could match Possessive Case?

Hi there,

I used default settings to create the indices on my data,while I found that
queries could not match Possessive Case.
For example, when I make a matchPhrasequery("Aharon Barak"), the documents
including strings such as "Aharon Barak's wife".
I have known that I need to set the word delimiter tokenfilter:
http://www.elasticsearch.org/guide/reference/index-modules/analysis/word-delimiter-tokenfilter/

From my understanding, I need to create the indices again after I change
the settings.
Is there any convenient means to handle this problem?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Also, I'm using ES 0.90.Beta

On Tuesday, April 23, 2013 8:44:22 PM UTC+8, Jingang Wang wrote:

Hi there,

I used default settings to create the indices on my data,while I found
that queries could not match Possessive Case.
For example, when I make a matchPhrasequery("Aharon Barak"), the
documents including strings such as "Aharon Barak's wife".
I have known that I need to set the word delimiter tokenfilter:
http://www.elasticsearch.org/guide/reference/index-modules/analysis/word-delimiter-tokenfilter/

From my understanding, I need to create the indices again after I change
the settings.
Is there any convenient means to handle this problem?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You do have to rebuild the index. There are currently no schema migrations
for elastic search.
If it isn't convenient to re-generate the data, you could do a scan of the
old index and insert each document into new index (server).

On Tuesday, April 23, 2013 5:53:06 AM UTC-7, Jingang Wang wrote:

Also, I'm using ES 0.90.Beta

On Tuesday, April 23, 2013 8:44:22 PM UTC+8, Jingang Wang wrote:

Hi there,

I used default settings to create the indices on my data,while I found
that queries could not match Possessive Case.
For example, when I make a matchPhrasequery("Aharon Barak"), the
documents including strings such as "Aharon Barak's wife".
I have known that I need to set the word delimiter tokenfilter:
http://www.elasticsearch.org/guide/reference/index-modules/analysis/word-delimiter-tokenfilter/

From my understanding, I need to create the indices again after I change
the settings.
Is there any convenient means to handle this problem?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thank you, Taras.
I have checked the word delimiter tokenfilter description.
Should I explicitly set it when put mapping? Would ES set it as default
settings?

On Wednesday, April 24, 2013 11:52:29 AM UTC+8, Taras Shkvarchuk wrote:

You do have to rebuild the index. There are currently no schema migrations
for elastic search.
If it isn't convenient to re-generate the data, you could do a scan of the
old index and insert each document into new index (server).

On Tuesday, April 23, 2013 5:53:06 AM UTC-7, Jingang Wang wrote:

Also, I'm using ES 0.90.Beta

On Tuesday, April 23, 2013 8:44:22 PM UTC+8, Jingang Wang wrote:

Hi there,

I used default settings to create the indices on my data,while I found
that queries could not match Possessive Case.
For example, when I make a matchPhrasequery("Aharon Barak"), the
documents including strings such as "Aharon Barak's wife".
I have known that I need to set the word delimiter tokenfilter:
http://www.elasticsearch.org/guide/reference/index-modules/analysis/word-delimiter-tokenfilter/

From my understanding, I need to create the indices again after I change
the settings.
Is there any convenient means to handle this problem?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.