How to make the "Discover" tab data to Table view

Hi,

Right now the default looks of the discover mode is not in table view, just wondering is there a setting to change the documents show in a table view, instead of document per document ?

Hi
Could you provide some details what default you would expect? Do you mean view when you're expanding a document? Or do you want functionality to aggregate data like our data table visualization does?
Thx & Best,
Matthias

Hi,

I would like each field name in each document in the index will appeared as a column in the the table in discover tab, right now it is not in that view.

if a document has username, city , phone number, gentle, address these four fields in a document. I would like to see 4 columns in the "red circle" that I circled below look like the table I ceeated in the sample table, right now the discover mode have a default setting and the data does not show in a form that I wanted.

image

to the left of your screen you can see that the available fields from your data are shown. when you hover over those fields it will show an option called "add". now you can add the required fields and save it. (Save your Discover search so you can use it in visualizations and dashboards)

Hi ,

I actually have created those tables as in what you have described above. I am wondering is there a way to set it as default when people click the discover mode, and they only see table vie.

Besides I have alias on each actual field name, and also have created index pattern for that with wildcard, but I am not sure why I am not able to see my alias name in discover mode from the selected index pattern, but only actual field name, and I only see three aliases with date type appeared in the discover mode , not the string type and the rest

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

You can set the default columns in our advanced settings:


Best,
Matthias

HI Mathias,

Thanks for the information, I configured the "Default coulmn" in the Discover in the "Advanced setting". But when I click the Discover tab, I still don't see those columns being appeared.

Maybe something wrong with how I set the configuration?

Advanced Setting

Discover

could you try using , instead of ; for delimiting you fields? Many thx!
Best,
Matthias

Hi,

I actually tried both ; and ,
But I still don’t any effect , just wondering what is the right way to use that configuration

/Kenneth

Should work, which version of Kibana are you using

I am using Kibana 7.3. Is that a feature for newer version?

Hi,

It s working now!
I try to open the "discover" in another browser or new tab, and now I can see the changes.

image

But there is still problems, I have different indices with different index patterns, each index consists of different fields, and when I switch the index pattern in the drop down list. It is still giving me the columns that I set for the first index pattern, it doesn't give me the fields for the other index. Is there away to configure "Default Columns" according to the selected index?

image

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.