How to proxy Kibana?

Hello. I'm having some(a lot of) difficulties, trying to setup a reverse proxy for Kibana.

The general idea is that we want to set up a reverse proxy so select customers have access to Kibana. E.g. when customer A goes to he is automatically forwarded to Kibana and has access to logistics about their data. We have multiple customers we need to proxy, so eventually we will set up ldap or AD, to help us handle this.

So far i've tried both Apache2 and Nginx, but i've run into problems using both of them. I'm currently working on Apache, with a very simple configuration.

When i go to localhost/kibana/ i'm forwarded to localhost/app/kibana, but i get a URL not found message.

As far as NginX goes, i run into a problem where i forward to Kibana, but it get's indefinitely stuck in a loading loop. ("Kibana is loading blablabla... good stuff will be cached"), but i never actually shows the dashboard, no matter which configuration i tried, i could never get the dashboard to show. This is a sample config, but it's changed a lot during testing.

Am i going about it the right way or is their a simpler way to do what i'm trying to do.

I've managed to achieve the same results with Apache2 now. Infinite loading loop.


Having the same problem myself, Kibana is just stuck at loading when proxied by Apache. Works just fine when i hit the Kibana instance directly.

Anyone figure this out yet? Any clue?

Same problem too.. any solution so far?

Sorry for the late reply, i've been sick with the flu for the last week.

We've successfully managed to create a proxy environment around our kibana solution. We're using Nginx though. I'm not sure whether this is a bug or not, but in order to keep the proxy loop from happening it seems you have to proxy using location "/" and not e.g. "/kibana". I'm not sure why, but it seems like it's this that causes the loop, at least that is how we fixed it.

Here's a sample vhost config file, that i can confirm works in my test environment using Centos and Debian machines.

Which version of Kibana you are using?
I am also having the same problem.

I'm currently proxying with 4.3

Did you use the server.basepath property on the Kibana.yml config file or only nginx configurations.
Actually I was trying both and it is not working for me.

I only used nginx configurations, try posting your configs and i'll have a look at them to check if they look like mine.

guys, it's actually very easy.

everything is explained in this post: [ 4.3.0 ] how to configure your nginx balancer and apache reverse proxy


This is the nginx config I am using.Link
I am not getting the relative URL back anymore .All subsequent URLs like common.js etc are now absolute to the sever root.