How to Re-Enable Shard Allocation

So we restarted our Elastic-Cluster last week, today i noticed that there are a lot unassigned Shards.
I thought my colleagues forgot to turn Shard - Allocation back on, which i can confirm by now.

I now i have to change it back in Order to get my Unassigned Shards away. But now if i try to do

 curl -XPUT "http://YY.XX.ZZZ.YXZ:9200/_cluster/settings" -d '{
    "transient" : {
        "cluster.routing.allocation.enable" : "all"

i get the following Error : {"error":"Content-Type header [application/x-www-form-urlencoded] is not supported","status":406}

Thanks for you help in advance guys!

You need to add:

-H 'Content-Type: application/json'

Thanks man, worked out.
Cluster is relocating Shards again!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.