How to restart a server if Elasticsearch encounters "too many files opened" error?

Hi good day,

I have an elasticsearch server hosted on a server ( it has 4 CPUs and 8GB
worth of ram ).
Everynow and than, i encounter an error which goes "too many files opened".

I fix this by rebooting the server, and than restarting the Elasticsearch
service.

May I know how do i automate this ?

Alternatively, is there a better one to avoid the "too many files opened"
error ? I googled around and i understand that i can increase the limit for
number of files opened for that server.
But is there a better solution ?

Best Regards.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hello!

Restarting the server is not the best way, you should rather fix the problem. Look at this tutorial - http://www.elasticsearch.org/tutorials/too-many-open-files/

The "Too many files opened" means that ElasticSearch doesn't have all the resources it needs to operate properly - in this case it can't create or open all the needed files, so you should increase your limit.

--

Regards,

Rafał Kuć

Sematext :: http://sematext.com/ :: Solr - Lucene - ElasticSearch

Hi good day,

I have an elasticsearch server hosted on a server ( it has 4 CPUs and 8GB worth of ram ).

Everynow and than, i encounter an error which goes "too many files opened".

I fix this by rebooting the server, and than restarting the Elasticsearch service.

May I know how do i automate this ?

Alternatively, is there a better one to avoid the "too many files opened" error ? I googled around and i understand that i can increase the limit for number of files opened for that server.

But is there a better solution ?

Best Regards.

--

You received this message because you are subscribed to the Google Groups "elasticsearch" group.

To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

Hello!

Restarting the server is not the best way, you should rather fix the
problem. Look at this tutorial -
http://www.elasticsearch.org/tutorials/too-many-open-files/

The "Too many files opened" means that ElasticSearch doesn't have all the
resources it needs to operate properly - in this case it can't create or
open all the needed files, so you should increase your limit.

--
Regards,
Rafał Kuć
Sematext :: http://sematext.com/ :: Solr - Lucene - ElasticSearch

W dniu czwartek, 8 sierpnia 2013 08:54:38 UTC+2 użytkownik ElasticSearch
Noob napisał:

Hi good day,

I have an elasticsearch server hosted on a server ( it has 4 CPUs and 8GB
worth of ram ).
Everynow and than, i encounter an error which goes "too many files opened".

I fix this by rebooting the server, and than restarting the Elasticsearch
service.

May I know how do i automate this ?

Alternatively, is there a better one to avoid the "too many files opened"
error ? I googled around and i understand that i can increase the limit for
number of files opened for that server.
But is there a better solution ?

Best Regards.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.