How to retrieve detailed mapping info for a field?


(Arkadiy Rudin) #1

Get mapping only returns the field type.
How to retrieve other fields values - like index, store, etc.?
Ark

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

If not explicity set by you, it means that defaults are used.

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 sept. 2013 à 05:58, Arkadiy Rudin arkrud85@gmail.com a écrit :

Get mapping only returns the field type.
How to retrieve other fields values - like index, store, etc.?
Ark

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Arkadiy Rudin) #3

On Thursday, September 19, 2013 12:32:39 AM UTC-4, David Pilato wrote:

If not explicity set by you, it means that defaults are used.

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 sept. 2013 à 05:58, Arkadiy Rudin <arkr...@gmail.com <javascript:>>
a écrit :

Get mapping only returns the field type.
How to retrieve other fields values - like index, store, etc.?
Ark

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Arkadiy Rudin) #4

I set some options explicity and I see them working when I query the index.
But GET mappings is not showing them.
So my question is - how I can see the options I set?

On Thursday, September 19, 2013 12:32:39 AM UTC-4, David Pilato wrote:

If not explicity set by you, it means that defaults are used.

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 sept. 2013 à 05:58, Arkadiy Rudin <arkr...@gmail.com <javascript:>>
a écrit :

Get mapping only returns the field type.
How to retrieve other fields values - like index, store, etc.?
Ark

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #5

Could you Gist a curl recreation?
I would like to understand what happens here.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 sept. 2013 à 14:49, Arkadiy Rudin arkrud85@gmail.com a écrit :

I set some options explicity and I see them working when I query the index.
But GET mappings is not showing them.
So my question is - how I can see the options I set?

On Thursday, September 19, 2013 12:32:39 AM UTC-4, David Pilato wrote:
If not explicity set by you, it means that defaults are used.

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 sept. 2013 à 05:58, Arkadiy Rudin arkr...@gmail.com a écrit :

Get mapping only returns the field type.
How to retrieve other fields values - like index, store, etc.?
Ark

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Arkadiy Rudin) #6

Hi David,

You were right and I was confused a bit.
Initially I had a index mapping with all defaults for my "string" type
field.
Then I added "index": "analyzed". After getting mappings back I was unable
to see this in the mapping JSON.
And it is correct becuase "analyzed" is default value.

I was ajusting the fileld only because I was searching using some of my
terms which started with uppercase letter (like Obama) and it was not
returning results. When searched with same term in all lovercase it is
returning results as expected.
I am new to ES and was using /head Structured Query interface which acts
this way with uppercase.
Is it by the way an expected behavier and how to make sure that query will
return hits on terms started with uppercase?

Thank You

Arkadiy

On Thursday, September 19, 2013 9:41:08 AM UTC-4, David Pilato wrote:

Could you Gist a curl recreation?
I would like to understand what happens here.

-- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 sept. 2013 à 14:49, Arkadiy Rudin <arkr...@gmail.com <javascript:>>
a écrit :

I set some options explicity and I see them working when I query the
index.
But GET mappings is not showing them.
So my question is - how I can see the options I set?

On Thursday, September 19, 2013 12:32:39 AM UTC-4, David Pilato wrote:

If not explicity set by you, it means that defaults are used.

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 sept. 2013 à 05:58, Arkadiy Rudin arkr...@gmail.com a écrit :

Get mapping only returns the field type.
How to retrieve other fields values - like index, store, etc.?
Ark

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #7

Run a match query (analyzed) instead of a term query (not analyzed).

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 sept. 2013 à 22:27, Arkadiy Rudin arkrud85@gmail.com a écrit :

Hi David,

You were right and I was confused a bit.
Initially I had a index mapping with all defaults for my "string" type field.
Then I added "index": "analyzed". After getting mappings back I was unable to see this in the mapping JSON.
And it is correct becuase "analyzed" is default value.

I was ajusting the fileld only because I was searching using some of my terms which started with uppercase letter (like Obama) and it was not returning results. When searched with same term in all lovercase it is returning results as expected.
I am new to ES and was using /head Structured Query interface which acts this way with uppercase.
Is it by the way an expected behavier and how to make sure that query will return hits on terms started with uppercase?

Thank You

Arkadiy

On Thursday, September 19, 2013 9:41:08 AM UTC-4, David Pilato wrote:

Could you Gist a curl recreation?
I would like to understand what happens here.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 sept. 2013 à 14:49, Arkadiy Rudin arkr...@gmail.com a écrit :

I set some options explicity and I see them working when I query the index.
But GET mappings is not showing them.
So my question is - how I can see the options I set?

On Thursday, September 19, 2013 12:32:39 AM UTC-4, David Pilato wrote:

If not explicity set by you, it means that defaults are used.

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 sept. 2013 à 05:58, Arkadiy Rudin arkr...@gmail.com a écrit :

Get mapping only returns the field type.
How to retrieve other fields values - like index, store, etc.?
Ark

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #8