How to send just one response header in Packetbeat?


(Eugene Glotov) #1

Hello.

I want to catch the 'x-custom' header in logstash from packetbeat. In configuration I have "send_headers" key, bit it is not working for response.

http:
    ...
    #    send_all_headers: true # with this option I can see all headers, but I don't need them all
    send_headers: ["x-custom"] # this doesn't work

(Monica Sarbu) #2

send_headers should work for both response and request. What version of Packetbeat are you using? I have tried the latest Packetbeat version and it works just fine for me. Can you please make sure the HTTP request contains such a header? Thanks!


(Eugene Glotov) #3

I have version 1.3.1. And yes, I can see the header in the response if send_all_headers option is on.
Ok, if this option should work with a both way, I'll try to test it again.


(system) #4

This topic was automatically closed after 21 days. New replies are no longer allowed.