How to set my aws elastic ip address in hosts?


(Aravinthan Asokan) #1

Hi

I am new to elasticsearch , just installed ES 2.1 , Logstash successfully.

I have used Ubuntu 14.04 in amazon web services. I can able to create index from data fetching from RDS using mysql jdbc input.

Even able to search using below url inside my server.
curl localhost:9200/joblisting_bootstrap/job/_search?q=Technical+Skills

If change the network.host my-ip-address
network.host: xx.xxx.xxx.xx
it is not working showing below error

Connection refused {:class=>"Manticore::SocketException", :level=>:error}
Logstash startup completed
Attempted to send a bulk request to Elasticsearch configured at '["http://xx.xxx.xxx.xx:9200/"]', but Elasticsearch appears to be unreachable or down! {:client_config=>{:hosts=>["http://xx.xxx.xxx.xx:9200/"], :ssl=>nil, :transport_options=>{:socket_timeout=>0, :request_timeout=>0, :proxy=>nil, :ssl=>{}}, :transport_class=>Elasticsearch::Transport::Transport::HTTP::Manticore, :logger=>nil, :tracer=>nil, :reload_connections=>false, :retry_on_failure=>false, :reload_on_failure=>false, :randomize_hosts=>false}, :error_message=>"Connection refused", :class=>"Manticore::SocketException", :level=>:error}

Is there any setting need to be done ? please help me to fix this issue

Thanks


(David Pilato) #2

Can you simply curl from another machine your instance?

Check the logs and make sure that 9200 port is bound to the right IP address. Check also if you have any firewall...


(system) #3