How to set search.highlight.term_vector_multi_value


(Shai Erera) #1

Hi, I want to change the value of search.highlight.term_vector_multi_value to false (so I get highlighted snippets across values of a multi-valued field) but I can't find documentation on how to change it. I tried to update the index settings, but I get unknown setting [index.search.highlight.term_vector_multi_value].... Any ideas?


(Shai Erera) #2

I also tried to update it via the cluster settings, but I get: "transient setting [search.highlight.term_vector_multi_value], not dynamically updateable" (likewise for persistent)


(Shai Erera) #3

Anyone? :slight_smile:


(Mark Harwood) #4

We shifted to explicitly maintaining a list of settings that are expected so we can fail loudly if someone provides any illegal setting. This requires a registry of all valid settings.

I can see the highlighter is trying to load the setting here but I've yet to find an entry in the registry of valid index settings. Need to keep looking further but at the moment it looks like a bug


(Shai Erera) #5

Thanks @Mark_Harwood. So if indeed it's a bug (I assume the bug is that the setting is not registered, and not that such setting even exists), how do you expect it will be set? As part of the "index" settings? Would appreciate if you can put here an example of how to configure it


(Simon Willnauer) #6

I opened https://github.com/elastic/elasticsearch/pull/22999 for this. you can't set it unless it's registered.


(Shai Erera) #7

Thanks @s1monw and I noticed the change also got merged. Would u mind pasting here how would I set it? Is it part of the index settings / node settings? Is it something I should set before the server starts? Thanks!


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.