How to set the query resultset size to infinite


(Nuno Carvalho) #1

Hi all,

I just joined the mailing list, so sorry if this topic was discussed before.

I would like to set the query size to infinite (or no limit).

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-request-from-size.html
This page explains what the parameters do, but there are no details on how
to set the size to "no limit" or (if not possible) what is the max value
accepted by ES for this parameter. I tried setting the value to -1, as I've
read somewhere that this would be recognized as "no limit", but instead it
defaults to 10.

Any help?

Thanks,
Nuno

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/73ad3559-85b0-40a0-9325-5ff2054f192d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

You don't want to do that!
If your need is to extract (download) 1 000 000 000 records, you need to use scan&scroll API: http://www.elasticsearch.org/guide/en/elasticsearch/guide/current/scan-scroll.html#scan-scroll

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 juin 2014 à 11:08:00, Nuno Carvalho (nunomrc@gmail.com) a écrit:

Hi all,

I just joined the mailing list, so sorry if this topic was discussed before.

I would like to set the query size to infinite (or no limit).

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-request-from-size.html
This page explains what the parameters do, but there are no details on how to set the size to "no limit" or (if not possible) what is the max value accepted by ES for this parameter. I tried setting the value to -1, as I've read somewhere that this would be recognized as "no limit", but instead it defaults to 10.

Any help?

Thanks,
Nuno

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/73ad3559-85b0-40a0-9325-5ff2054f192d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53a3fe27.3352255a.198d%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Nuno Carvalho) #3

Right... that makes sense :slight_smile:

I'll give it a try, thank you!

Nuno

On Friday, 20 June 2014 10:26:07 UTC+1, David Pilato wrote:

You don't want to do that!
If your need is to extract (download) 1 000 000 000 records, you need to
use scan&scroll API:
http://www.elasticsearch.org/guide/en/elasticsearch/guide/current/scan-scroll.html#scan-scroll

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 20 juin 2014 à 11:08:00, Nuno Carvalho (nun...@gmail.com <javascript:>)
a écrit:

Hi all,

I just joined the mailing list, so sorry if this topic was discussed
before.

I would like to set the query size to infinite (or no limit).

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-request-from-size.html
This page explains what the parameters do, but there are no details on
how to set the size to "no limit" or (if not possible) what is the max
value accepted by ES for this parameter. I tried setting the value to -1,
as I've read somewhere that this would be recognized as "no limit", but
instead it defaults to 10.

Any help?

Thanks,
Nuno

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/73ad3559-85b0-40a0-9325-5ff2054f192d%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/73ad3559-85b0-40a0-9325-5ff2054f192d%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/49dbec8b-765a-4647-8672-b556028dcea0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4