How to set-up elastic maven reposiroty


(lukasSirhal) #1

Hi,
i fallowed this x-pack api-java, but i still this error when run mvn dependency:tree or mvn install...

[ERROR] Failed to execute goal on project es-service: Could not resolve dependencies for project cz.datalite.es:es-service:jar:5.0.0-SNAPSHOT: Failure to find org.elasticsearch.client:x-pack-transport:jar:5.1.1 in http://zealot:8081/artifactory/repo was cached in the local repository, resolution will not be reattempted until the update interval of repo has elapsed or updates are forced

I tried set-up our artifactory but if i add elastic repository https://artifacts.elastic.co/maven and test the connection i get 404 error page not found. Do anybody know how set-up artifactory properly?

Thanks


Error - XPack Class not found Exception in java
(David Pilato) #2

But even if you have the 404 error, are you able to add this repository on artifactory?


(lukasSirhal) #3

Yes I'am able to add remote repository to artifactory but only add.
But still i have trouble with download any dependency from eleastic repository


(David Pilato) #4

I think the URL is correct so probably something you need to fix in artifactory.

May be clean maven cache (force update) and start again?


(lukasSirhal) #5

Hello,

yes URL is realy correct but when i add new remote repository, and click to "test" button it run to "not found" error.

But it does no matter, because when i run mvn clean install -U it is work perfect.
Thanks for hints


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.