How to specifiy proxy with websoket input plugin

Hello all,

I would need to use the logstash websocket as input plugin.
I installed it and it works.
However, I'm not able to retrieve data from the websocket URL.
The case is simple.
In order to reach internet, my logstash server needs to use a web proxy.
The Linux proxy env variables are set up to use a web proxy. And the network tcpdump shows me that logstash still tries to reach the websocket directly and not via the proxy.
Here my logstash config:

 input {
      websocket {
        id => "my_plugin_id"
        url => ""
        tags => ["ris"]

According the websocket plugin documention, there is no option to specifiy a web proxy.
Is it something which is supported ?

Thank you,


I do not think so. There is an open issue on FTW for this (and that is what the input uses).

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.