How to start elastic search in brower after installation of xpack zip in elastic search in Windows machine


(John) #1

I was installed elastic search using zip folder in Windows machine.
Xpack zip installed in elastic search...

How to start elastic search in Windows machine ,How to authenticate in brower?
Is there any Pop up will come to authenticate,If yes,How,where popup will come?
How to change password for elastic search?
Any help Greatly appreciate...
Thanks
Saida


(Alexander Reelsen) #2

Hey

have you worked through the installation guide of x-pack

https://www.elastic.co/guide/en/elasticsearch/reference/6.2/installing-xpack-es.html

especially the part about setup-passwords

--Alex


(John) #3

Thank for Quick Response.
yes.
I gone through it. I I was installed through xpack.zip,elasticsearch.zip,etc.zip. i haven't given any password and desired output file while calling "xpack\certutil ca" simply just pressed enter.
It placed by default elasticsearch.keystore in Config Folder and elastic-stack-ca.p12 in bin.
1)Where Could i move to the elastic-stack-ca.p12 in which folder?
2)I was added elasticsearch.yml file as bellow,is it correct?
##xpack.ssl.truthstore.path:bin\ealstic-certificates.p12
##xpack.ssl.keystore.path:bin\elastic-certficates.p12
##xpack.seurity.transport.enabled:true
##xpacksecurity.transport.ss.verification_mode:certified
##xpack.security.http.ssl.enabled;true##

I am getting Exception as 733 Main Error No Log4j2 configuration file found.
set system property log4j2.debug to show log4j2 internal initializtion logging....
Sytem Expception failed load setting from the elasticsearch.yml

Could u share elastic search .yml file which was configured...?
Please help ....


(John) #4

I am using xpack trail version


(Tim Vernum) #5

certutil places the file in the current directory, if it placed it in bin it's because you ran it from bin.

The documentation states:

Copy the node certificate to the appropriate locations

Copy the applicable .p12 file into a directory within the Elasticsearch configuration directory on each node. ...
There is no need to copy the CA file to this directory.

You need to put the elastic-certificates.p12 file into your config/ directory. Elasticsearch will refuse to read files that are outside of the expected directories (this is a security protection).

You do not need to put the "elastic-stack-ca.p12" anywhere. You might want to keep it so that you can generate additional node certificates in the future, but elasticsearch does not need a copy of it.

"certified" is incorrect, it must be "certificate". From the docs referenced above:

xpack.security.transport.ssl.verification_mode: certificate

This is a problem, but seems to be unrelated. Can you post the exact error message please.

Please copy-and-paste the exact message you received.


(John) #6

Hi TimV,
As you said that's right. ....

I am getting Missing type:Security Exception,Missing Authentication token for Rest Request[/]
in elasticsearch..
I am getting Login Currently disabled.Administrator should consult the kibana logs for more detail. in Kibana....
Any clue that what i missed?
What could i do?
Thanks,
John


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.