How to sync the index data in a cluster


#1

The cluster was in trouble, and the disk space was full. I removed some old
index data by running curl -XDELETE
'localhost:9200/logstash-2014.04.28?pretty'. In the meantime, there were 2
data nodes were out of the cluster. Not sure what happened. But after I
restarted all the nodes in the cluster, including these 2 data nodes. I
found some old index data on these 2 data nodes were not removed as
expected, I could understand because they were out of the cluster when I
performed the curl command at the first time. I can remove the newer index
data, but cannot remove those old index data that should be removed when I
ran curl command at the first time. How can I sync these index data in a
cluster? I mean to remove those old index data by cluster on these 2 data
nodes automatically. Or may I just run rm command to remove these old index
data (logstash-2014.04.28 - logstash-2014.04.5.15)?

data node in trouble:
-bash-4.1$ curl -XDELETE 'localhost:9200/logstash-2014.04.28?pretty'
{
"error" :
"RemoteTransportException[[edc-prod-caredlogs-app1][inet[/10.63.64.176:9300]][indices/delete]];
nested: IndexMissingException[[logstash-2014.04.28] missing]; ",
"status" : 404
}
-bash-4.1$ ls
kibana-int logstash-2014.05.05 logstash-2014.05.14
logstash-2014.06.12 logstash-2014.06.20 logstash-2014.06.29
logstash-2014.04.28 logstash-2014.05.06 logstash-2014.05.15
logstash-2014.06.13 logstash-2014.06.21 logstash-2014.07.01
logstash-2014.04.29 logstash-2014.05.07 logstash-2014.06.06
logstash-2014.06.14 logstash-2014.06.23 logstash-2014.07.02
logstash-2014.04.30 logstash-2014.05.08 logstash-2014.06.07
logstash-2014.06.15 logstash-2014.06.24 logstash-2014.07.03
logstash-2014.05.01 logstash-2014.05.09 logstash-2014.06.08
logstash-2014.06.16 logstash-2014.06.25 logstash-2014.07.04
logstash-2014.05.02 logstash-2014.05.10 logstash-2014.06.09
logstash-2014.06.17 logstash-2014.06.26 logstash-2014.07.05
logstash-2014.05.03 logstash-2014.05.12 logstash-2014.06.10
logstash-2014.06.18 logstash-2014.06.27 logstash-2014.07.07
logstash-2014.05.04 logstash-2014.05.13 logstash-2014.06.11
logstash-2014.06.19 logstash-2014.06.28

data node with correct index data:
-bash-4.1$ ls
kibana-int logstash-2014.06.11 logstash-2014.06.17
logstash-2014.06.24 logstash-2014.06.30 logstash-2014.07.06
logstash-2014.06.06 logstash-2014.06.12 logstash-2014.06.18
logstash-2014.06.25 logstash-2014.07.01 logstash-2014.07.07
logstash-2014.06.07 logstash-2014.06.13 logstash-2014.06.19
logstash-2014.06.26 logstash-2014.07.02
logstash-2014.06.08 logstash-2014.06.14 logstash-2014.06.20
logstash-2014.06.27 logstash-2014.07.03
logstash-2014.06.09 logstash-2014.06.15 logstash-2014.06.21
logstash-2014.06.28 logstash-2014.07.04
logstash-2014.06.10 logstash-2014.06.16 logstash-2014.06.23
logstash-2014.06.29 logstash-2014.07.05

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/55df1d6b-c5d3-403a-8825-b69e4fc1a34a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2