How to use 'crypto' / 'crypto-browserify' in Kibana plugin?


(Eskampette) #1

Hello,

From my Kibana plugin app, I am trying to use "require('crypto');" / "require('crypto-browserify');".

On Kibana, I am facing the following error:

I am wondering what did I miss? Or is it even possible to use those modules?

Best Regards,
Antoine.


(Shaunak Kashyap) #2

I ran into this error too recently. I've just created a bug for it: https://github.com/elastic/kibana/issues/11619.


(Eskampette) #3

Thank you very much Shaunak.

I will follow this issue closely.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.