Http_host only binds to 127.0.0.1


(Juanccert) #1

I'm trying to communicate my logstash instance with another host in a different LAN but I can't get my instance work in a different IP than the localhost: 127.0.0.1.

This is my config settings:

http.host:"172.20.25.69"

# Bind port for the metrics REST endpoint, this option also accept a range
#(9600-9700) and logstash will pick up the first available ports.

http.port: 9600-9700

but when running logstash i can't communicate with no other host because I get logstash listening on
0.0.0.0:5144 for incoming log traffic.

[INFO ] 2018-06-21 11:09:13.535 [[main]<udp] udp - UDP listener started {:address=>"0.0.0.0:5144", :receive_buffer_bytes=>"106496", :queue_size=>"2000"}

[INFO ] 2018-06-21 11:09:13.555 [Ruby-0-Thread-1: /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/task.rb:22] pipeline - Pipeline started succesfully {:pipeline_id=>"main", :thread=>"#<Thread:0x6b1ff06d@/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:246 run>"}

[INFO ] 2018-06-21 11:09:13.567 [Ruby-0-Thread-1: /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/task.rb:22] agent - Pipelines running {:count=>1, :pipelines=>["main"]


(Magnus Bäck) #2

but when running logstash i can't communicate with no other host because I get logstash listening on
0.0.0.0:5144 for incoming log traffic.

But that's good. 0.0.0.0 means all network interfaces.


(Juanccert) #3

Thanks! I thought that was wrong.
The case is that I'm getting a connection refused while trying to sends logs to my logstash instance. The host where my instance is running responds with ICMP type=3 code= 10 meaning that the host is rejecting the incoming traffic.


(Magnus Bäck) #4

What are you using to send to Logstash? Have you verified with e.g. netstat that Logstash actually is listening on the port in question? Can you send data to that port from the same host? What's the firewall situation?


(Juanccert) #5

Thansk again.

It was I firewall isssue. The firewall daemon of the host was rejecting the the incoming packets on any unusual port.
I'm using a firewall for sending los to logstash.
netstat verified that the host was listening on that port.

I disabled the host firewall and it start receiving the logs


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.