Http input is not letting beat input to run

I running in a strange situation where i have 2 seperate pipeline running on a same instance.

When I run the beats pipeline alone it works properly but as soon as I create the http-input.conf in the different directory or basically starts the http input pipeline too , beats pipeline failed with error :

[2024-02-09T07:11:46,559][ERROR][logstash.javapipeline ][beatspipeline] Pipeline error {:pipeline_id=>"beatspipeline", :exception=>#<NameError: cannot link Java class io.netty.handler.ssl.OpenSsl, probable missing dependency: io.netty.internal.tcnative.SSLContext.setCipherSuite(JLjava/lang/String;Z)Z>, :backtrace=>["org/jruby/javasupport/JavaClass.java:292:in for_name'", "org/jruby/javasupport/JavaClass.java:288:in for_name'", "org/jruby/javasupport/JavaUtilities.java:39:in get_proxy_class'", "uri:classloader:/jruby/java/core_ext/object.rb:44:in block in java_import'", "org/jruby/RubyArray.java:2577:in map'", "uri:classloader:/jruby/java/core_ext/object.rb:37:in java_import'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-beats-6.0.3-java/lib/logstash/inputs/beats.rb:138:in register'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:228:in block in register_plugins'", "org/jruby/RubyArray.java:1809:in each'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:227:in register_plugins'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:386:in start_inputs'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:311:in start_workers'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:185:in run'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:137:in block in start'"]

I have also tried adding cipher_suites => "TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256" by seeing this post Http input on different pipeline breaks beats pipeline , but none of it helped.

Hello and welcome,

You will need to provide more context.

Please share both of your Logstash configurations using the Preformatted text option, the </> button in the post editor.

Also share how are you running logstash. Are you running as a service? Using the command line? Share your pipelines.yml as well and please tell which version of Logstash you are running.