Http output not working : http output failure for Logstash 5.0[SOLVED]


(Ritesh) #1

Hi All

Here is my output conf file, i am not able to post data to endpoint

output {
    http {
      url => "https://abcd.com/dataEventRequests"
         http_method => "post"
         content_type => "application/vnd.abcd.resourceitem+json"
         headers => {
   "Authorization" => "Basic SENNX0lNUEw6SnJvOTg0ODM="
   "Host" => "abcd.com:443"
   "Accept-Encoding" => "gzip,deflate"
   "Content-Length" => "292"
         }
         format => "json"
   message =>'{"sourceId":"ABCD_EFG","requestNumber":"1234","requestTimestamp":"2017-01-12T08:00:00.000-08:00"}'

    }
    }

My output is in JSON format, i checked in SOAP UI it is working well.

Here is the error that you get in log file

[2017-01-13T17:51:54,686][ERROR][logstash.outputs.http ] [HTTP Output Failure] Could not fetch URL {:url=>"https://abcd.com/dataEventRequests",..........................

Again this working well for me in the SOAP UI using REST projects


(Ritesh) #2

@wiibaa

Hi wiibaa, is there any documentation for this, so that i make sure my http output in conf file is correct


(Ritesh) #3

its working for me now.

No issues

I gave header with "Cookie" and it worked.
Looks like http output plugin does not take care of cookie on its own


(Graham D) #4

can you please provide an example of what you changed? I am trying to use a loopback address in my config and i keep getting the same error as you. Wondering if i have the same issue.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.