HTTPS input to Logstash


(Varsha Krishna Shakti) #1

Hi,
I am new to ELK. I am using Logstash Version: 2.4.0
I need to configure my Logstash to accept HTTPS Input only. I don't need any certificate Validation.

I have tried some configuration with HTTP Input. But, was unable to get success.


(Magnus Bäck) #2

What did you try? In what way did it not work?


(Varsha Krishna Shakti) #3

I have tried below configurations:

input {
http {
host => "127.0.0.1"
port => "8080"
ssl => true

}
}

Error : "LogStash::ConfigurationError"

input {
http {
host => "127.0.0.1"
port => "8080"
}
}

when I am trying to provide Https Input, It gives "HTTP parse error"
Error: HTTP parse error, malformed request (): #<Puma::HttpParserError: Invalid HTTP format, parsing fails.>
ENV: {"rack.version"=>[1, 3], "rack.errors"=>#IO:fd2, "rack.multithread"=>true, "rack.multiprocess"=>false, "rack.run_once"=>false, "SCRIPT_NAME"=>"", "QUERY_STRING"=>"", "SERVER_PROTOCOL"=>"HTTP/1.1", "SERVER_SOFTWARE"=>"2.16.0", "GATEWAY_INTERFACE"=>"CGI/1.2"}


(Magnus Bäck) #4

Error : "LogStash::ConfigurationError"

Please provide the full error message.


(Varsha Krishna Shakti) #5

Please find below full error message:

[31mPipeline aborted due to error {:exception=>"LogStash::ConfigurationError",:backtrace=>["logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-input-http-2.2.3/lib/logstash/inputs/http.rb:97:in register'","logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:330:instart_inputs'", "org/jruby/RubyArray.java:1613:in each'", "logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:329:instart_inputs'", "logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:180:in start_workers'", "logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/pipeline.rb:136:inrun'", "logstash-2.4.0/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/agent.rb:491:in `start_pipeline'"], :level=>:error}←[0mstopping pipeline {:id=>"main"}The signal HUP is in use by the JVM and will not work correctly on this platform


(Magnus Bäck) #6

There's the error message that should've been included: "Settings :keystore and :keystore_password are required because :ssl is enabled."


(Varsha Krishna Shakti) #7

I have cross checked again. I am not getting such error in Error Meassage.


(Magnus Bäck) #8

Sorry, I meant that that's the error message that Logstash should've included. The error message is emitted by the code but it never shown to the user.


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.