Human-readable output option needs some additions


(Brian Yoder) #1

Adding the human=true parameter is useful, but it only seems to be applied
to the byte counts. For example, when looking at my local MacBook's running
instance, and isolating just the process and Java information, the "heap_init"
: "256mb" is added to reflect the "heap_init_in_bytes" : 268435456 value.

However, the "start_time" : 1393519068785 is completely unreadable to all
but the very rarest of humans. It would be nice to see "start_time_human" :
"2014-02-27T16:37:48.785Z" in addition.

And the "refresh_interval" : 1000 is readable, but it would be nice if it
had a human readable form of "refresh_interval_human" : "1s" in addition.

$ curl -XGET
'http://localhost:9200/_nodes/process,jvm?pretty=true&human=true' && echo
{
"cluster_name" : "brian-exploration",
"nodes" : {
"QZrJz9xEQWKNVvg1mKaNCQ" : {
"name" : "dynamic-126",
"transport_address" : "inet[/192.168.90.126:9300]",
"host" : "dynamic-126.florida.local",
"ip" : "192.168.90.126",
"version" : "1.0.0",
"build" : "a46900e",
"http_address" : "inet[/192.168.90.126:9200]",
"attributes" : {
"max_local_storage_nodes" : "1"
},
"process" : {
"refresh_interval" : 1000,
"id" : 3688,
"max_file_descriptors" : 10240,
"mlockall" : false
},
"jvm" : {
"pid" : 3688,
"version" : "1.7.0_51",
"vm_name" : "Java HotSpot(TM) 64-Bit Server VM",
"vm_version" : "24.51-b03",
"vm_vendor" : "Oracle Corporation",
"start_time" : 1393519068785,
"mem" : {
"heap_init" : "256mb",
"heap_init_in_bytes" : 268435456,
"heap_max" : "989.8mb",
"heap_max_in_bytes" : 1037959168,
"non_heap_init" : "23.1mb",
"non_heap_init_in_bytes" : 24313856,
"non_heap_max" : "130mb",
"non_heap_max_in_bytes" : 136314880,
"direct_max" : "989.8mb",
"direct_max_in_bytes" : 1037959168
},
"gc_collectors" : [ "ParNew", "ConcurrentMarkSweep" ],
"memory_pools" : [ "Code Cache", "Par Eden Space", "Par Survivor
Space", "CMS Old Gen", "CMS Perm Gen" ]
}
}
}
}

Brian

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/807372fc-802f-4389-b6ea-0e3b412787a2%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Sean Gallagher) #2

Hi Brian,
Those are good suggestions. I've filed them
as https://github.com/elasticsearch/elasticsearch/issues/5280. Thanks!

Sean

On Thursday, February 27, 2014 3:47:34 PM UTC-5, InquiringMind wrote:

Adding the human=true parameter is useful, but it only seems to be
applied to the byte counts. For example, when looking at my local MacBook's
running instance, and isolating just the process and Java information, the "heap_init"
: "256mb" is added to reflect the "heap_init_in_bytes" : 268435456 value.

However, the "start_time" : 1393519068785 is completely unreadable to all
but the very rarest of humans. It would be nice to see "start_time_human"
: "2014-02-27T16:37:48.785Z" in addition.

And the "refresh_interval" : 1000 is readable, but it would be nice if it
had a human readable form of "refresh_interval_human" : "1s" in addition.

$ curl -XGET '
http://localhost:9200/_nodes/process,jvm?pretty=true&human=true' && echo
{
"cluster_name" : "brian-exploration",
"nodes" : {
"QZrJz9xEQWKNVvg1mKaNCQ" : {
"name" : "dynamic-126",
"transport_address" : "inet[/192.168.90.126:9300]",
"host" : "dynamic-126.florida.local",
"ip" : "192.168.90.126",
"version" : "1.0.0",
"build" : "a46900e",
"http_address" : "inet[/192.168.90.126:9200]",
"attributes" : {
"max_local_storage_nodes" : "1"
},
"process" : {
"refresh_interval" : 1000,
"id" : 3688,
"max_file_descriptors" : 10240,
"mlockall" : false
},
"jvm" : {
"pid" : 3688,
"version" : "1.7.0_51",
"vm_name" : "Java HotSpot(TM) 64-Bit Server VM",
"vm_version" : "24.51-b03",
"vm_vendor" : "Oracle Corporation",
"start_time" : 1393519068785,
"mem" : {
"heap_init" : "256mb",
"heap_init_in_bytes" : 268435456,
"heap_max" : "989.8mb",
"heap_max_in_bytes" : 1037959168,
"non_heap_init" : "23.1mb",
"non_heap_init_in_bytes" : 24313856,
"non_heap_max" : "130mb",
"non_heap_max_in_bytes" : 136314880,
"direct_max" : "989.8mb",
"direct_max_in_bytes" : 1037959168
},
"gc_collectors" : [ "ParNew", "ConcurrentMarkSweep" ],
"memory_pools" : [ "Code Cache", "Par Eden Space", "Par Survivor
Space", "CMS Old Gen", "CMS Perm Gen" ]
}
}
}
}

Brian

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d324d62f-7bc1-4375-939d-0031c184401a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3