I can´t find the metric index pattern and I have installed metricbeat


(Diego Moreno) #1


(ruflin) #2

The metricbeat-* pattern does not start with a .. Try without it.


(Diego Moreno) #3

It still does not work, Ruflin


(ruflin) #4

Is metricbeat running as expected? Can you check which indices exist? https://www.elastic.co/guide/en/elasticsearch/reference/current/cat-indices.html


(Diego Moreno) #5

No, it does not appear the metricbeat index pattern


(ruflin) #6

I assume you mean the indices?

Can you share your metricbeat log and config?


(Diego Moreno) #7

#========================== Modules configuration ============================

metricbeat.config.modules:

Glob pattern for configuration loading

path: ${path.config}/modules.d/*.yml

Set to true to enable config reloading

reload.enabled: true

Period on which files under path should be checked for changes

reload.period: 10s

#==================== Elasticsearch template setting ==========================

setup.template.settings:
index.number_of_shards: 1
index.codec: best_compression
#_source.enabled: false
setup.template.fields: "C:/Users/diego/Documents/MetricBeat/Metricbeat/fields.yml"

#================================ General =====================================

The name of the shipper that publishes the network data. It can be used to group

all the transactions sent by a single shipper in the web interface.

#name:

The tags of the shipper are included in their own field with each

transaction published.

#tags: ["service-X", "web-tier"]

Optional fields that you can specify to add additional information to the

output.

#fields:

env: staging

#============================== Dashboards =====================================

These settings control loading the sample dashboards to the Kibana index. Loading

the dashboards is disabled by default and can be enabled either by setting the

options here, or by using the -setup CLI flag or the setup command.

#setup.dashboards.enabled: false

The URL from where to download the dashboards archive. By default this URL

has a value which is computed based on the Beat name and version. For released

versions, this URL points to the dashboard archive on the artifacts.elastic.co

website.

#setup.dashboards.url:

#============================== Kibana =====================================

Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.

This requires a Kibana endpoint configuration.

setup.kibana:
host: "localhost:5601"

Kibana Host

Scheme and port can be left out and will be set to the default (http and 5601)

In case you specify and additional path, the scheme is required: http://localhost:5601/path

IPv6 addresses should always be defined as: https://[2001:db8::1]:5601

#============================= Elastic Cloud ==================================

These settings simplify using metricbeat with the Elastic Cloud (https://cloud.elastic.co/).

The cloud.id setting overwrites the output.elasticsearch.hosts and

setup.kibana.host options.

You can find the cloud.id in the Elastic Cloud web UI.

#cloud.id:

The cloud.auth setting overwrites the output.elasticsearch.username and

output.elasticsearch.password settings. The format is <user>:<pass>.

#cloud.auth:

#================================ Outputs =====================================

Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:

Array of hosts to connect to.

hosts: ["localhost:9200"]
enabled: true
pipeline: "ngnix_log_pipeline"
index: "metricbeat-%{[beat.version]}-%{+yyyy.MM}"

Optional protocol and basic auth credentials.

protocol: "https"
path: /elasticsearch
#username: "elastic"
#password: "changeme"

setup.template.name: "metricbeat-6.3.0-darwin-x86_64"
setup.template.enable: true
setup.template.pattern: "metricbeat-"
setup.dashboards.index: "metricbeat-
"
setup.template.fields: "fields.yml"

#----------------------------- Logstash output --------------------------------
#output.logstash:

The Logstash hosts

#hosts: ["localhost:5044"]

output.logstash:
enabled: true
hosts: ["localhost:5044"]

Optional SSL. By default is off.

List of root certificates for HTTPS server verifications

#ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

Certificate for SSL client authentication

#ssl.certificate: "/etc/pki/client/cert.pem"

Client Certificate Key

#ssl.key: "/etc/pki/client/cert.key"

#================================ Logging =====================================

Sets log level. The default log level is info.

Available log levels are: error, warning, info, debug

#logging.level: debug

At debug level, you can selectively enable logging only for some components.

To enable all selectors use ["*"]. Examples of other selectors are "beat",

"publish", "service".

#logging.selectors: ["*"]

#============================== Xpack Monitoring ===============================

metricbeat can export internal metrics to a central Elasticsearch monitoring

cluster. This requires xpack monitoring to be enabled in Elasticsearch. The

reporting is disabled by default.

Set to true to enable the monitoring reporter.

#xpack.monitoring.enabled: false

Uncomment to send the metrics to Elasticsearch. Most settings from the

Elasticsearch output are accepted here as well. Any setting that is not set is

automatically inherited from the Elasticsearch output configuration, so if you

have the Elasticsearch output configured, you can simply uncomment the

following line.

#xpack.monitoring.elasticsearch:

output.console:
enabled: true
pretty: true

metricbeat.modules:

  • module: system
    metricsets:

    • cpu
    • filesystem
    • memory
    • network
    • process
      enabled: true
      period: 5s
      processes: ['.*']
      cpu_ticks: false
  • module: apache
    metricsets: ["status"]
    enabled: true
    period: 1s
    hosts: ["http://localhost"]


(Andrew Cholakian) #8

Can you please reformat your config as code? You just need to wrap precede the code with a line consistent of three ticks. See this page for guidance on doing so.

Is that the complete log output in that screenshot?


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.