I dont get results for plurals if I use Snowball


(Vishal Sharma-2) #1

Hi,

I want to configure elastic for plurals so that searching for "blog" and
"blogs" return same results.

I found on internet that the way to go is to use Snowball analyzer. When I
use Snowball I get same results for both "blog" and "blogs". But, the
results which used to come for "blogs" without the snowball analyzer in
query do not come at all now.

Can someone please help?

http://myserver:9200/_search?analyzer=snowball&q=blogs&pretty

http://myserver:9200/_search?analyzer=snowball&q=blog&pretty

Vishal Sharma
Team Leader, SFDCT: +1 30­4 636 7373
E: vishals@grazitti.com
www.grazitti.com [image: Description: LinkedIn]
http://www.linkedin.com/company/grazitti-interactive[image: Description:
Twitter] https://twitter.com/grazitti[image: fbook]
https://www.facebook.com/grazitti.interactiveSession at Developer
*Track *on 3rd June[image: Button]
http://go.grazitti.com/meet-us-at-Lithium-LiNC-2015-conference.html

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGMB1maq4FutP7ODWToEvj65wXX99jK4kXhn0UPZDF-X-6rECg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Vishal Sharma-2) #2

I see its an issue with match: _all query.

Cant we get analyzer work with _all query?

Any help is appreciated.

Vishal Sharma
Team Leader, SFDCT: +1 30­4 636 7373
E: vishals@grazitti.com
www.grazitti.com [image: Description: LinkedIn]
http://www.linkedin.com/company/grazitti-interactive[image: Description:
Twitter] https://twitter.com/grazitti[image: fbook]
https://www.facebook.com/grazitti.interactiveSession at Developer
*Track *on 3rd June[image: Button]
http://go.grazitti.com/meet-us-at-Lithium-LiNC-2015-conference.html

On Fri, May 22, 2015 at 4:23 PM, Vishal Sharma vishals@grazitti.com wrote:

Hi,

I want to configure elastic for plurals so that searching for "blog" and
"blogs" return same results.

I found on internet that the way to go is to use Snowball analyzer. When I
use Snowball I get same results for both "blog" and "blogs". But, the
results which used to come for "blogs" without the snowball analyzer in
query do not come at all now.

Can someone please help?

http://myserver:9200/_search?analyzer=snowball&q=blogs&pretty

http://myserver:9200/_search?analyzer=snowball&q=blog&pretty

Vishal Sharma
Team Leader, SFDCT: +1 30­4 636 7373
E: vishals@grazitti.com
www.grazitti.com [image: Description: LinkedIn]
http://www.linkedin.com/company/grazitti-interactive[image:
Description: Twitter] https://twitter.com/grazitti[image: fbook]
https://www.facebook.com/grazitti.interactiveSession at Developer
*Track *on 3rd June[image: Button]
http://go.grazitti.com/meet-us-at-Lithium-LiNC-2015-conference.html

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGMB1maNJpad5VwEZOEDx3jb_GAnRB2kb06Pyd68gQP5aN8XNw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Jun Ohtani) #3

You can see
https://www.elastic.co/guide/en/elasticsearch/guide/current/root-object.html#all-field
about _all field.

"It uses the default analyzer to analyze its values"

PS - We're moving to https://discuss.elastic.co/, please join us there for
any future discussions!

2015-05-22 22:37 GMT+09:00 Vishal Sharma vishals@grazitti.com:

I see its an issue with match: _all query.

Cant we get analyzer work with _all query?

Any help is appreciated.

Vishal Sharma
Team Leader, SFDCT: +1 30­4 636 7373
E: vishals@grazitti.com
www.grazitti.com [image: Description: LinkedIn]
http://www.linkedin.com/company/grazitti-interactive[image:
Description: Twitter] https://twitter.com/grazitti[image: fbook]
https://www.facebook.com/grazitti.interactiveSession at Developer
*Track *on 3rd June[image: Button]
http://go.grazitti.com/meet-us-at-Lithium-LiNC-2015-conference.html

On Fri, May 22, 2015 at 4:23 PM, Vishal Sharma vishals@grazitti.com
wrote:

Hi,

I want to configure elastic for plurals so that searching for "blog" and
"blogs" return same results.

I found on internet that the way to go is to use Snowball analyzer. When
I use Snowball I get same results for both "blog" and "blogs". But, the
results which used to come for "blogs" without the snowball analyzer in
query do not come at all now.

Can someone please help?

http://myserver:9200/_search?analyzer=snowball&q=blogs&pretty

http://myserver:9200/_search?analyzer=snowball&q=blog&pretty

Vishal Sharma
Team Leader, SFDCT: +1 30­4 636 7373
E: vishals@grazitti.com
www.grazitti.com [image: Description: LinkedIn]
http://www.linkedin.com/company/grazitti-interactive[image:
Description: Twitter] https://twitter.com/grazitti[image: fbook]
https://www.facebook.com/grazitti.interactiveSession at Developer
*Track *on 3rd June[image: Button]
http://go.grazitti.com/meet-us-at-Lithium-LiNC-2015-conference.html

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGMB1maNJpad5VwEZOEDx3jb_GAnRB2kb06Pyd68gQP5aN8XNw%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAGMB1maNJpad5VwEZOEDx3jb_GAnRB2kb06Pyd68gQP5aN8XNw%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--

Jun Ohtani
blog : http://blog.johtani.info

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAPW8A5yw2Px57Uad3D4tujgX3ev%2BO5Vh3R2JL1ZhZz%2BJ-iB_Ng%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4