I don't know why "_source" :{"enabled":false} is not invalid?


(huangshanjay) #1

curl -XPOST http://localhost:9200/index/fulltext/ -d'
{
"mappings":
{
"default" :
{
"term_vector": "no",
"indexAnalyzer": "mmseg",
"searchAnalyzer": "mmseg",
"dynamic_date_formats" : ["yyyy-MM-dd"],
"dynamic_templates":[{"store_generic":{"match":"*","mapping":{"store":true}}}],
"_source" :{"enabled":false}
}
}
}'

then,

curl -XPOST
'http://localhost:9200/index/_http://localhost:9200/index/fulltext/_search
-d '
{
"query": { "query_string" : { "query" : "xxx" } }
}'

reponse:
{"took":2,"timed_out":false,"_shards":{"total":5,"successful":5,"failed":0},"hits":{"total":1,"max_score":0.095891505,"hits":[{"_index":"index","_type":"fulltext","_id":"1","_score":0.095891505,
"_source" :
{content:"xxx"}
}]}}

_source is return,am i wrong?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e11f72c0-3e39-4220-bf39-bb5a2d7c7a20%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

Did you recreate your index/type (so reindex your docs)?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 8 août 2014 à 08:18, huangshanjay@gmail.com a écrit :

curl -XPOST http://localhost:9200/index/fulltext/ -d'
{
"mappings":
{
"default" :
{
"term_vector": "no",
"indexAnalyzer": "mmseg",
"searchAnalyzer": "mmseg",
"dynamic_date_formats" : ["yyyy-MM-dd"],
"dynamic_templates":[{"store_generic":{"match":"*","mapping":{"store":true}}}],
"_source" :{"enabled":false}
}
}
}'

then,

curl -XPOST 'http://localhost:9200/index/_http://localhost:9200/index/fulltext/_search -d '
{
"query": { "query_string" : { "query" : "xxx" } }
}'

reponse:
{"took":2,"timed_out":false,"_shards":{"total":5,"successful":5,"failed":0},"hits":{"total":1,"max_score":0.095891505,"hits":[{"_index":"index","_type":"fulltext","_id":"1","_score":0.095891505, "_source" :
{content:"xxx"}
}]}}

_source is return,am i wrong?

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e11f72c0-3e39-4220-bf39-bb5a2d7c7a20%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8F6B9614-8B1F-432B-A5A7-B6EFC63E0B24%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(system) #3