I Have a Recovered cluster but unassigned can some one help


(Danny Crossby) #1

99abc 4 r UNASSIGNED CLUSTER_RECOVERED
99abc 2 r UNASSIGNED CLUSTER_RECOVERED
99abc 1 r UNASSIGNED CLUSTER_RECOVERED
99abc 3 r UNASSIGNED CLUSTER_RECOVERED
99abc 0 r UNASSIGNED CLUSTER_RECOVERED


(David Pilato) #2

If it's a cloud instance, please read https://discuss.elastic.co/t/now-live-new-elastic-cloud-standard-support/841611 for how to request support for Elastic Cloud :slight_smile:


(Danny Crossby) #3

no its not cloud instance


(David Pilato) #4

Can you give more details then about what and how this happened. What are the logs? Any pending tasks ?


(MJay) #5

I ran into same issue. After cluster recovery due to the network connectivity issue, 20 shards from 2 indices are in UNASSIGNED state for the time series index. Now the cluster state is RED. Looking into the option of recovering those UNASSIGNED indices so that the cluster state can become GREEN. No pending tasks as such.


(Danny Crossby) #6

if u can please help on this error

ES2.2.0

{
   "error":{
      "root_cause":[
         {
            "type":"illegal_argument_exception",
            "reason":"[allocate] allocation of [99ats][0] on node {Silhouette}{XGIzwCotTNSoYDiTiJgw5Q}{127.0.0.1}{127.0.0.1:9300} is not allowed, reason: [YES(allocation disabling is ignored)][YES(no allocation awareness enabled)][YES(no active primary shard yet)][YES(total shard limit disabled: [index: -1, cluster: -1] <= 0)][YES(node passes include/exclude/require filters)][THROTTLE(too many shards currently recovering [4], limit: [2])][YES(allocation disabling is ignored)][YES(only a single data node is present)][NO(primary shard is not yet active)][NO(shard cannot be allocated on same node [XGIzwCotTNSoYDiTiJgw5Q] it already exists on)][YES(shard not primary or relocation disabled)]"
         }
      ],
      "type":"illegal_argument_exception",
      "reason":"[allocate] allocation of [99ats][0] on node {Silhouette}{XGIzwCotTNSoYDiTiJgw5Q}{127.0.0.1}{127.0.0.1:9300} is not allowed, reason: [YES(allocation disabling is ignored)][YES(no allocation awareness enabled)][YES(no active primary shard yet)][YES(total shard limit disabled: [index: -1, cluster: -1] <= 0)][YES(node passes include/exclude/require filters)][THROTTLE(too many shards currently recovering [4], limit: [2])][YES(allocation disabling is ignored)][YES(only a single data node is present)][NO(primary shard is not yet active)][NO(shard cannot be allocated on same node [XGIzwCotTNSoYDiTiJgw5Q] it already exists on)][YES(shard not primary or relocation disabled)]"
   },
   "status":400
}

(David Pilato) #7

Please format your code. I edited your post to make that readable.

too many shards currently recovering [4], limit: [2]

I believe you need to wait that the first 2 shards are finished recovering.

It's unclear to me what command you actually ran and the reason you are in this situation.

BTW you should upgrade to latest 2.x version.


(MJay) #8

Let me know If I have to have a different post. Just don't wanted to interfere in this conversation. After the cluster recovery two time series indices were in UNASSIGNED state. Any idea why it happens during cluster recovery and how to recover the UNASSIGNED shards? Since the Primary is also in UNASSIGNED state, the cluster is RED. I don't want to delete those indices.


(MJay) #9

The elasticsearch version is 5.4.3.


(Danny Crossby) #10
$ curl -XGET localhost:9200/_cat/shards?h=index,shard,prirep,state,unassigned.reason| grep UNASSIGNED
99ats 3 r UNASSIGNED   CLUSTER_RECOVERED
99ats 1 r UNASSIGNED   CLUSTER_RECOVERED
99ats 4 r UNASSIGNED   CLUSTER_RECOVERED
99ats 2 p UNASSIGNED   ALLOCATION_FAILED
99ats 2 r UNASSIGNED   CLUSTER_RECOVERED
99ats 0 r UNASSIGNED   CLUSTER_RECOVERED

(David Pilato) #11

Yes open another thread as it will be confusing otherwise.


(David Pilato) #12

What is the status on this now?

99ats 2 p UNASSIGNED ALLOCATION_FAILED

I believe you should see things in logs.


(system) #13

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.