I have primitive fields and disabled norms on all text fields, the nvd file still created and occupies ~2GB space?


(Urvish Mahida) #1

I have datetimes, ip fields, numeric fields and text/keyword fields. I have explicitly disabled norms on text & keyword fields. Why is lucene creating nvd files in segments still ? and why is in order of GB for 36GB index ?
If i disable doc values on datetimes, ip fields, numeric fields since I am not doing any aggregation and filtering on them should i expect the dvd file to decrease in size as well ?


(Christian Dahlqvist) #2

Which version of Elasticsearch are you using? What does your mappings look like?


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.