I was deploying docker and ran into a problem, unable to access port 3002

Add the Enterprise Search host URL to the Kibana configuration
In the config/kibana.yml file, set enterpriseSearch.host to the URL of the Enterprise Search instance. For example:

enterpriseSearch.host: 'http://localhost:3002'

I installed Elasticsearchedit and kibana and accessed the enterprise search prompt settings of the kibana panel, but I didn't seem to find the service port at all. Is there something wrong with my settings?

Version 8.9.2

Typically, “localhost” in docker is only available inside that container, but not outside the container. You’d need to expose a host through the host gateway. Depending on your docker implementation, there may be a default. For example, on Mac’s Docker Desktop, you can use “host.docker.internal” to reference the host that the container is running on.

Alternatively, you can create a network, or reference the service by its name rather than host. Check out these docs: Run Enterprise Search server using Docker images | Enterprise Search documentation [8.9] | Elastic

Thanks. What I tried to deploy was the normal version of Elasticsearch and the corresponding Kibana.


Do I need to delete the regular version and redeploy the enterprise version of es?

Because of Kibana8.9.2, I didn’t find a way to use the regular version directly.It worked before. But reinstalled. I lost past steps.

Do I need to deploy an integration to switch it from the Enterprise Edition to the Standard Edition? It seems to me that the regular version does not have 3002?

Or is it that Kibana can only be adapted to enterprise version search, and ordinary ones cannot be adapted?

But it seems that the linkware was successfully enabled before.

Do I have to use Enterprise Edition to configure 3002 correctly?

thank you. i am a newbie

thank you.

Hi @qinskysky ,

I think there's some confusion here about the different products you're working with.

Elasticsearch (docker instructions) is a storage backend. It is its own service. Its commonly used port is 9200.

Elastic Enterprise Search (docker instructions) is built on top of Elasticsearch, and is the service that provides Elastic App Search. It exposes port 3002. In order to use Elastic Enterprise Search, it must be able to connect to a running instance of Elasticsearch.

Elasticsearch has several license levels - Basic (free), Gold, Platinum, and Enterprise. Confusingly, Enterprise Elasticsearch (license) is totally unrelated to Elastic Enterprise Search, despite the similarity in naming. Sorry about that :see_no_evil: .

All the docker guides provide examples, but are just that - examples. While they might showcase different configurations or approaches, they should all be using the same "versions" of these products.

  • Elasticsearch image: docker.elastic.co/elasticsearch/elasticsearch:<version>
  • Enterprise Search image: docker.elastic.co/enterprise-search/enterprise-search:<version>
  • Kibana image: docker.elastic.co/kibana/kibana:<version>

I hope that helps. :slight_smile:

Thanks. When I was using 8.9.2 Mulan, the search inside was enterprise search. I don't know how to change it to a normal search. Currently 10.1, the search is displayed directly after installation.

problem solved.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.